diff mbox series

[bug#61823] gnu: Add tmux-plugin-continuum.

Message ID 20230311210134.12015-1-eu@euandre.org
State New
Headers show
Series [bug#61823] gnu: Add tmux-plugin-continuum. | expand

Commit Message

EuAndreh March 11, 2023, 9:01 p.m. UTC
* gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
---

This version addresses the new linter offense that the CI raised.

 gnu/packages/tmux.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Greg Hogan May 16, 2023, 8:01 p.m. UTC | #1
On Sat, Mar 11, 2023 at 4:21 PM EuAndreh via Guix-patches via
<guix-patches@gnu.org> wrote:
>
> * gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
> ---
>
> This version addresses the new linter offense that the CI raised.
>
>  gnu/packages/tmux.scm | 41 +++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
>
> diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
> index 67ce18fea1..9a2ab7ffbe 100644
> --- a/gnu/packages/tmux.scm
> +++ b/gnu/packages/tmux.scm
> @@ -317,3 +317,44 @@ (define-public tmux-plugin-resurrect
>  @end itemize")
>        (home-page "https://github.com/tmux-plugins/tmux-resurrect/")
>        (license license:expat))))
> +
> +(define-public tmux-plugin-continuum
> +  (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
> +        (revision "0"))
> +    (package
> +      (name "tmux-plugin-continuum")
> +      (version (git-version "0" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/tmux-plugins/tmux-continuum/")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                  "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
> +      (build-system trivial-build-system)
> +      (arguments
> +       `(#:modules ((guix build utils))
> +         #:builder (begin
> +                     (use-modules (guix build utils))
> +                     (let ((out (string-append %output
> +                                 "/share/tmux-plugins/continuum/")))
> +                       (mkdir-p out)
> +                       (copy-recursively (assoc-ref %build-inputs "source")
> +                                         out)))))
> +      (synopsis "Continous saving of tmux environment")

Continous -> Continuous (thanks spell check!)

> +      (description
> +       "Features:
> +
> +@itemize
> +@item continuous saving of tmux environment
> +@item automatic tmux start when computer/server is turned on
> +@item automatic restore when tmux is started
> +@end itemize
> +
> +Together, these features enable uninterrupted tmux usage.  No matter the
> +computer or server restarts, if the machine is on, tmux will be there how you
> +left it off the last time it was used.")
> +      (home-page "https://github.com/tmux-plugins/tmux-continuum/")
> +      (license license:expat))))
> --
> 2.39.2

I am able to load and configure settings for this plugin. I have not
been able to fully test the operation due to my use of "oh my tmux"
and the challenges of integrating into the status bar. The patch looks
good to my eyes other than the synopsis spelling noted above.
EuAndreh May 17, 2023, 12:27 p.m. UTC | #2
Also, I have been running the 
tmux-plugin-continuum+tmux-plugin-resurrect combo for some months now 
with no hiccups so far.
diff mbox series

Patch

diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 67ce18fea1..9a2ab7ffbe 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -317,3 +317,44 @@  (define-public tmux-plugin-resurrect
 @end itemize")
       (home-page "https://github.com/tmux-plugins/tmux-resurrect/")
       (license license:expat))))
+
+(define-public tmux-plugin-continuum
+  (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
+        (revision "0"))
+    (package
+      (name "tmux-plugin-continuum")
+      (version (git-version "0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/tmux-plugins/tmux-continuum/")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
+      (build-system trivial-build-system)
+      (arguments
+       `(#:modules ((guix build utils))
+         #:builder (begin
+                     (use-modules (guix build utils))
+                     (let ((out (string-append %output
+                                 "/share/tmux-plugins/continuum/")))
+                       (mkdir-p out)
+                       (copy-recursively (assoc-ref %build-inputs "source")
+                                         out)))))
+      (synopsis "Continous saving of tmux environment")
+      (description
+       "Features:
+
+@itemize
+@item continuous saving of tmux environment
+@item automatic tmux start when computer/server is turned on
+@item automatic restore when tmux is started
+@end itemize
+
+Together, these features enable uninterrupted tmux usage.  No matter the
+computer or server restarts, if the machine is on, tmux will be there how you
+left it off the last time it was used.")
+      (home-page "https://github.com/tmux-plugins/tmux-continuum/")
+      (license license:expat))))