diff mbox series

[bug#62100,v3,02/16] gnu: python-jupytext: Replace python-pre-commit with pre-commit.

Message ID 20230311133945.7770-2-antero@mailbox.org
State New
Headers show
Series [bug#62100,v3,01/16] gnu: pre-commit: Update to 3.1.1. | expand

Commit Message

Antero Mejr March 11, 2023, 1:39 p.m. UTC
* gnu/packages/python-xyz.scm (python-jupytext)[native-inputs]: Remove
python-pre-commit.
[native-inputs]: Add pre-commit.
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83f3ec02ea..4d76ab9bf6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -351,6 +351,7 @@  (define-public python-jupytext
                                                       " and not "))))))))))
     (native-inputs
      (list git-minimal
+           pre-commit
            python-autopep8
            python-black
            python-flake8
@@ -358,7 +359,6 @@  (define-public python-jupytext
            python-isort
            python-ipython-genutils
            python-jupyter-server
-           python-pre-commit
            python-pytest
            python-pyaml))
     (propagated-inputs