diff mbox series

[bug#62100,v3,15/16] gnu: python-pre-commit: Replace with pre-commit.

Message ID 20230311133945.7770-15-antero@mailbox.org
State New
Headers show
Series [bug#62100,v3,01/16] gnu: pre-commit: Update to 3.1.1. | expand

Commit Message

Antero Mejr March 11, 2023, 1:39 p.m. UTC
* gnu/packages/python-xyz.scm (python-pre-commit): Deprecate in favor of
pre-commit.
---
 gnu/packages/python-xyz.scm | 29 +----------------------------
 1 file changed, 1 insertion(+), 28 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e910f33a29..02ec564e8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24287,34 +24287,7 @@  (define-public python-retrying
     (license license:asl2.0)))
 
 (define-public python-pre-commit
-  (package
-    (name "python-pre-commit")
-    (version "2.10.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "pre_commit" version))
-       (sha256
-        (base32 "1ycf6wpxrhxhdzz0vpryhbdxlwik5khgcvp3hxwvfr447a6k84zl"))))
-    (build-system python-build-system)
-    (arguments
-     ;; Tests fail with "AttributeError: module 'pre_commit.resources' has no
-     ;; attribute 'empty_template_setup'".
-     `(#:tests? #false))
-    (propagated-inputs
-     (list python-cfgv
-           python-identify
-           python-importlib-metadata
-           python-nodeenv
-           python-pyyaml
-           python-toml
-           python-virtualenv))
-    (home-page "https://github.com/pre-commit/pre-commit")
-    (synopsis "Framework for managing multi-language pre-commit hooks")
-    (description
-     "This package provides a framework for managing and maintaining
-multi-language pre-commit hooks.")
-    (license license:expat)))
+  (deprecated-package "python-pre-commit" pre-commit))
 
 (define-public python-precis-i18n
   (package