diff mbox series

[bug#62098] gnu: Add r-hdcytodata.

Message ID 20230310161612.26795-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#62098] gnu: Add r-hdcytodata. | expand

Commit Message

nafkhamdc March 10, 2023, 4:16 p.m. UTC
* gnu/packages/bioconductor.scm (r-hdcytodata): New variable.
---
 gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Christopher Baines June 3, 2023, 11:15 a.m. UTC | #1
Navid Afkhami <navid.afkhami@mdc-berlin.de> writes:

> * gnu/packages/bioconductor.scm (r-hdcytodata): New variable.
> ---
>  gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
>  1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
> index d603bd42c1..1cf33501d6 100644
> --- a/gnu/packages/bioconductor.scm
> +++ b/gnu/packages/bioconductor.scm
> @@ -560,6 +560,46 @@ (define-public r-hdo-db
>  https://github.com/DiseaseOntology/HumanDiseaseOntology/tree/main/src/ontology}.")
>      (license license:artistic2.0)))

Looks like this was committed as
f7682c247504d252cf86b274ffe7b8f62670b497.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d603bd42c1..1cf33501d6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -560,6 +560,46 @@  (define-public r-hdo-db
 https://github.com/DiseaseOntology/HumanDiseaseOntology/tree/main/src/ontology}.")
     (license license:artistic2.0)))
 
+(define-public r-hdcytodata
+  (package
+    (name "r-hdcytodata")
+    (version "1.18.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "HDCytoData" version
+                                     'experiment))
+              (sha256
+               (base32
+                "1fn8q6ds10z3ymdarkfyh88pcqnrry9yhzammp84vf86f0bl8mrc"))))
+    (properties `((upstream-name . "HDCytoData")))
+    (build-system r-build-system)
+    (arguments
+     (list #:phases '(modify-phases %standard-phases
+                       (add-after 'unpack 'set-HOME
+                         (lambda _
+                           (setenv "HOME" "/tmp")))
+                       (add-after 'unpack 'avoid-internet-access
+                         (lambda _
+                           (setenv "GUIX_BUILD" "yes")
+                           (substitute* "R/zzz.R"
+                             (("createHubAccessors.*" m)
+                              (string-append
+                               "if (Sys.getenv(\"GUIX_BUILD\") == \"\") {" m
+                               "}"))))))))
+    (propagated-inputs (list r-experimenthub r-flowcore r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/lmweber/HDCytoData")
+    (synopsis
+     "Set of high-dimensional flow cytometry and mass cytometry benchmark datasets")
+    (description
+     "HDCytoData contains a set of high-dimensional cytometry benchmark datasets.
+These datasets are formatted into SummarizedExperiment and flowSet
+Bioconductor object formats, including all required metadata.  Row metadata
+includes sample IDs, group IDs, patient IDs, reference cell population or
+cluster labels and labels identifying spiked in cells.  Column metadata
+includes channel names, protein marker names, and protein marker classes.")
+    (license license:expat)))
+
 (define-public r-homo-sapiens
   (package
     (name "r-homo-sapiens")