diff mbox series

[bug#62049] gnu: Add texlive-onedown.

Message ID 20230308140132.14308-1-mail@nicolasgoaziou.fr
State New
Headers show
Series [bug#62049] gnu: Add texlive-onedown. | expand

Commit Message

Nicolas Goaziou March 8, 2023, 2:01 p.m. UTC
* gnu/packages/tex.scm (texlive-onedown): New variable.
---
 gnu/packages/tex.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)


base-commit: 237b175858873fe051954779bdde28c82ed64063

Comments

Ludovic Courtès March 16, 2023, 9:45 p.m. UTC | #1
Hi,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

> * gnu/packages/tex.scm (texlive-onedown): New variable.

LGTM, thanks!

Ludo’.
Nicolas Goaziou March 17, 2023, 8:24 a.m. UTC | #2
Hello,

Ludovic Courtès <ludo@gnu.org> writes:


> Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:
>
>> * gnu/packages/tex.scm (texlive-onedown): New variable.
>
> LGTM, thanks!

Applied. Thank you for the feedback.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f178bafcc2..0c4e545edf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3508,6 +3508,50 @@  (define-public texlive-oberdiek
 
 (define-deprecated-package texlive-latex-oberdiek texlive-oberdiek)
 
+(define-public texlive-onedown
+  (let ((template
+         (simple-texlive-package
+          "texlive-onedown"
+          (list "doc/latex/onedown/"
+                "source/latex/onedown/"
+                "tex/latex/onedown/")
+          (base32
+           "04ih7i4v96ggwk4k1mpfx3dzcpi2siqablv93wryg7dk4cks5wkl"))))
+    (package
+      (inherit template)
+      (outputs '("doc" "out"))
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ #t) "latex/onedown")
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _ (chdir "source/latex/onedown/")))
+              (replace 'copy-files
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (texmf (string-append #$output "/share/texmf-dist"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (for-each
+                     (lambda (directory)
+                       (copy-recursively (string-append origin directory)
+                                         (string-append texmf directory)))
+                     '("/source" "/tex/latex/onedown"))
+                    (copy-recursively (string-append origin "/doc")
+                                      doc))))))))
+      (home-page "https://ctan.org/pkg/onedown")
+      (synopsis "Typeset bridge diagrams")
+      (description
+       "This is a comprehensive package to draw all sorts of bridge diagrams,
+including hands, bidding tables, trick tables, and expert quizzes.
+
+It works for all font sizes.  Different fonts for hands, bidding diagrams and
+compass are possible.  It also provides annotations to card and bidding
+diagrams, automated check on consistency of suit and hands, and multilingual
+output of bridge terms.")
+      (license license:lppl1.3+))))
+
 (define-public texlive-latex-rerunfilecheck
   (package
     (inherit (simple-texlive-package