diff mbox series

[bug#61975] gnu: i3-wm: Add missing propagated inputs.

Message ID 20230305062848.13101-1-seerlite@disroot.org
State New
Headers show
Series [bug#61975] gnu: i3-wm: Add missing propagated inputs. | expand

Commit Message

SeerLite March 5, 2023, 6:28 a.m. UTC
perl-anyevent-i3 is necessary to run i3-save-tree.

* gnu/packages/wm.scm (i3-wm)[propagated-inputs]: Add perl and perl-anyevent-i3.
---
 gnu/packages/wm.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

宋文武 March 6, 2023, 8:30 a.m. UTC | #1
SeerLite <seerlite@disroot.org> writes:

> perl-anyevent-i3 is necessary to run i3-save-tree.
>
> * gnu/packages/wm.scm (i3-wm)[propagated-inputs]: Add perl and perl-anyevent-i3.
> ---
>  gnu/packages/wm.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 5b8dbd5c70..8816f110bb 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -356,6 +356,8 @@ (define-public i3-wm
>             startup-notification
>             pango
>             cairo))
> +    (propagated-inputs
> +     (list perl perl-anyevent-i3))

Hello, this can also be done by 'wrap-program' i3-save-tree with
PERL5LIB.  And a wrapper is considered better than propagated-input here
due to the latter will introduce perl and its libraries into user's
profile, which may not be what a typical i3 user want and will also
increase the chance of conflicts in profile.

Could you send an update patch to use 'wrap-program' for i3-save-tree?
Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5b8dbd5c70..8816f110bb 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -356,6 +356,8 @@  (define-public i3-wm
            startup-notification
            pango
            cairo))
+    (propagated-inputs
+     (list perl perl-anyevent-i3))
     (native-inputs
      (list which
            perl