diff mbox series

[bug#61969,core-updates] gnu: patchelf: Update to 0.17.2.

Message ID 20230304225825.3080-1-winter@winter.cafe
State New
Headers show
Series [bug#61969,core-updates] gnu: patchelf: Update to 0.17.2. | expand

Commit Message

Winter March 4, 2023, 10:58 p.m. UTC
* gnu/packages/elf.scm (patchelf): Update to 0.17.2.
[uri]: Use the release tarballs posted to GitHub releases, which have
superseded the ones hosted on releases.nixos.org.
[arguments]: Add fixes for two tests added since the last update.
[properties]: Remove release-monitoring-url, as the GitHub updater will
be used now that the releases are hosted there.
---
 gnu/packages/elf.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: a56eafd28bdafda9824a6a85e1ab974b8210f9bb
diff mbox series

Patch

diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 6ef09399d4..3074d22d7d 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -247,16 +247,16 @@  (define-public libelf
 (define-public patchelf
   (package
     (name "patchelf")
-    (version "0.11")
+    (version "0.17.2")
     (source (origin
              (method url-fetch)
              (uri (string-append
-                   "https://nixos.org/releases/patchelf/patchelf-"
+                   "https://github.com/NixOS/patchelf/releases/download/"
                    version
                    "/patchelf-" version ".tar.bz2"))
              (sha256
               (base32
-               "16ms3ijcihb88j3x6cl8cbvhia72afmfcphczb9cfwr0gbc22chx"))))
+               "1qnql97ghbb7nhv9zpm4ip0cqj05xyyxk391jv0j5r3jc0vymqms"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -271,6 +271,14 @@  (define-public patchelf
                ;; Find libgcc_s.so, which is necessary for the test:
                (("/xxxxxxxxxxxxxxx") (string-append (assoc-ref inputs "gcc:lib")
                                                     "/lib")))
+             (substitute* "tests/replace-needed.sh"
+               ;; This test assumes that only libc will be linked alongside
+               ;; libfoo when we explictly link libgcc_s. (It passes when using Nixpkgs'
+               ;; toolchain because of special casing: https://github.com/NixOS/patchelf/blob/65bf3d9dc12d994e73694a49c0813d753071d450/tests/Makefile.am#L73-L74.)
+               (("grep -v 'foo\\\\.so'") "grep -E 'libc.*\\.so'"))
+             (substitute* "tests/set-empty-rpath.sh"
+               ;; Binaries with empty RPATHs cannot run on Guix.
+               (("^\\$\\{SCRATCH\\}\\/simple.$") ""))
              #t)))))
     (native-inputs
      `(("gcc:lib" ,gcc "lib")))
@@ -279,9 +287,6 @@  (define-public patchelf
     (description
      "PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
 changed.")
-    ;; This can probably be removed with the next release.
-    (properties
-     '((release-monitoring-url . "https://github.com/NixOS/patchelf/releases")))
     (license gpl3+)))
 
 (define-public libdwarf