diff mbox series

[bug#61947,1/2] gnu: Fix kernel source infodoc patching for linux-libre >= 6.2.

Message ID 20230304003517.15072-1-leo@famulari.name
State New
Headers show
Series [bug#61947,1/2] gnu: Fix kernel source infodoc patching for linux-libre >= 6.2. | expand

Commit Message

Leo Famulari March 4, 2023, 12:35 a.m. UTC
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>

* gnu/packages/linux.scm (doc-supported?): Rename to ...
(apply-infodoc-patch?): ... new variable with different kernel version
constraints.
(make-linux-libre): Adjust accordingly.
---
 gnu/packages/linux.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8e01d505ab..be14869f70 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -863,10 +863,12 @@  (define (config->string options)
 ;;; Kernel package utilities.
 ;;;
 
-(define (doc-supported? version)
+(define (apply-infodoc-patch? version)
   ;; Versions older than 5.10 have different enough build scripts that the
   ;; infodocs patch doesn't apply.
-  (version>=? version "5.10"))
+  (and (version>=? version "5.10")
+       (not (version>=? version "6.2")))) ;patch applied upstream
+
 
 (define* (make-linux-libre version gnu-revision hash-string supported-systems
                            #:key
@@ -879,7 +881,7 @@  (define* (make-linux-libre version gnu-revision hash-string supported-systems
                            (extra-options %default-extra-linux-options)
                            (patches
                             `(,%boot-logo-patch
-                              ,@(if (doc-supported? version)
+                              ,@(if (apply-infodoc-patch? version)
                                     (list (search-patch
                                            "linux-libre-infodocs-target.patch"))
                                     '()))))