diff mbox series

[bug#61931] gnu: Add r-oscope.

Message ID 20230303105625.36854-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61931] gnu: Add r-oscope. | expand

Commit Message

nafkhamdc March 3, 2023, 10:56 a.m. UTC
* gnu/packages/bioconductor.scm (r-oscope): New variable.
---
 gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Ricardo Wurmus March 3, 2023, 11:05 a.m. UTC | #1
Thanks for the patch.  I have applied it with commit
4f681cdbc27e6a922f24d4297efe3c0b823195f0.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 22be8d3772..78eb24625f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7425,6 +7425,32 @@  (define-public r-organismdbi
 the fact that each of these packages implements a select methods.")
     (license license:artistic2.0)))
 
+(define-public r-oscope
+  (package
+    (name "r-oscope")
+    (version "1.28.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "Oscope" version))
+              (sha256
+               (base32
+                "0454f9yc0jmg3mcq9264wb5v2n8n0kaf801hlvsiy1xa3baj3h29"))))
+    (properties `((upstream-name . "Oscope")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biocparallel r-cluster r-ebseq r-testthat))
+    (home-page "https://bioconductor.org/packages/Oscope")
+    (synopsis
+     "Scillatory genes identifier in unsynchronized single cell RNA-seq")
+    (description
+     "Oscope is a oscillatory genes identifier in unsynchronized single cell RNA-seq.
+This statistical pipeline has been developed to identify and recover the
+base cycle profiles of oscillating genes in an unsynchronized single cell
+RNA-seq experiment.  The Oscope pipeline includes three modules: a sine model
+module to search for candidate oscillator pairs; a K-medoids clustering module
+to cluster candidate oscillators into groups; and an extended nearest insertion
+module to recover the base cycle order for each oscillator group.")
+    (license license:asl2.0)))
+
 (define-public r-pcaexplorer
   (package
     (name "r-pcaexplorer")