diff mbox series

[bug#61928,2/2] gnu: rnp: Improve package style.

Message ID 20230303043713.18948-2-jackhill@jackhill.us
State New
Headers show
Series Update and style-ize rnp | expand

Commit Message

Jack Hill March 3, 2023, 4:37 a.m. UTC
* gnu/package/openpgp.scm (rnp)[phases]{fixes}: Rename fixes to patch-tests, use
search-input-file, and remove trailing #t.
{check}: Respect tests?.
[native-inputs]: Remove labels.
[home-page]: Update URL.
---
 gnu/packages/openpgp.scm | 30 +++++++++++++++---------------
 1 file changed, 15 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/openpgp.scm b/gnu/packages/openpgp.scm
index 422e9bdcd6..9b6f04b407 100644
--- a/gnu/packages/openpgp.scm
+++ b/gnu/packages/openpgp.scm
@@ -118,23 +118,23 @@  (define-public rnp
                      "-DDOWNLOAD_RUBYRNP=off")
                    #:phases
                    (modify-phases %standard-phases
-                     (add-after 'unpack 'fixes
-                       (lambda* (#:key inputs #:allow-other-keys)
+                     (add-after 'unpack 'patch-tests
+                       (lambda _
                          (substitute* "src/tests/support.cpp"
-                           (("\"cp\"") (string-append "\"" (which "cp") "\"")))
-                         #t))
+                           (("\"cp\"") (search-input-file inputs "/bin/cp")))))
                      (replace 'check
-                       (lambda _
-                         ;; Some OpenPGP certificates used by the tests expire.
-                         ;; To work around that, set the time to roughly the
-                         ;; release date.
-                         (invoke "faketime" ,day-of-release "make" "test"))))))
+                       (lambda* (#:key tests? #:allow-other-keys)
+                         (when tests?
+                           ;; Some OpenPGP certificates used by the tests expire.
+                           ;; To work around that, set the time to roughly the
+                           ;; release date.
+                           (invoke "faketime" ,day-of-release "make" "test")))))))
       (native-inputs
-       `(("gnupg" ,gnupg) ; for tests
-         ("googletest" ,googletest)
-         ("libfaketime" ,libfaketime) ; for tests
-         ("pkg-config" ,pkg-config)
-         ("python" ,python)))
+       (list gnupg       ; for tests
+             googletest  ; for tests
+             libfaketime ; for tests
+             pkg-config
+             python))
       (inputs (list botan bzip2 json-c zlib))
       (synopsis
        "RFC4880-compliant OpenPGP library written in C++")
@@ -146,7 +146,7 @@  (define-public rnp
 librnp is the library used by rnp for all OpenPGP functions, useful for
 developers to build against.  It is a “real” library, not a wrapper like GPGME
 of GnuPG.")
-      (home-page "https://www.rnpgp.com/")
+      (home-page "https://www.rnpgp.org/")
       (license
        ;; RNP contains code written by Ribose and code derived from netpgp.
        (list