diff mbox series

[bug#61921] gnu: Add r-oscope.

Message ID 20230302164803.71966-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61921] gnu: Add r-oscope. | expand

Commit Message

nafkhamdc March 2, 2023, 4:48 p.m. UTC
* gnu/packages/bioconductor.scm (r-oscope): New variable.
---
 gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ricardo Wurmus March 3, 2023, 11:57 a.m. UTC | #1
Superseded by issue 61931.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2bfca85bbc..c4fb44f7b2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1702,6 +1702,37 @@  (define-public r-curatedtcgadata
 across the entire multi-'omics experiment.")
     (license license:artistic2.0)))
 
+(define-public r-oscope
+  (let ((commit "32e0ea72236128731f35a60fb5abcde5b5d35433")
+        (revision "1"))
+    (package
+      (name "r-oscope")
+      (version (git-version "1.29.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.bioconductor.org/packages/Oscope")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "02929i7zd4fwdhxi0h2i7y3sn6v1k3srahn5a6v9wvihp5nmgcig"))))
+      (properties `((upstream-name . "Oscope")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-biocparallel r-cluster r-ebseq r-testthat))
+      (home-page "https://git.bioconductor.org/packages/Oscope")
+      (synopsis
+       "Oscillatory genes identifier in unsynchronized single cell RNA-seq")
+      (description
+       "Oscope is a oscillatory genes identifier in unsynchronized single cell RNA-seq.
+This statistical pipeline has been developed to identify and recover the
+base cycle profiles of oscillating genes in an unsynchronized single cell
+RNA-seq experiment.  The Oscope pipeline includes three modules: a sine model
+module to search for candidate oscillator pairs; a K-medoids clustering module
+to cluster candidate oscillators into groups; and an extended nearest insertion
+module to recover the base cycle order for each oscillator group.")
+      (license license:asl2.0))))
+
 (define-public r-parathyroidse
   (package
     (name "r-parathyroidse")