diff mbox series

[bug#61891]

Message ID 20230301072343.708693-5-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61891] | expand

Commit Message

Mădălin Ionel Patrașcu March 1, 2023, 7:23 a.m. UTC
Date: Thu, 23 Feb 2023 01:35:43 +0100
Subject: [PATCH 5/7] gnu: Add r-metagenomeseq.

* gnu/packages/bioconductor.scm (r-metagenomeseq): New variable.
---
 gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4b5ec7db28..7de5750e09 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6644,6 +6644,39 @@  (define-public r-maser
 and visualizaton of alternative splicing events generated by rMATS.")
     (license license:expat)))
 
+(define-public r-metagenomeseq
+  (package
+    (name "r-metagenomeseq")
+    (version "1.40.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "metagenomeSeq" version))
+       (sha256
+        (base32 "01wjw4kcm8ysa5sn3cqg4a9i5pyksnwmbdqp5fr6n2l9hllkc9jy"))))
+    (properties `((upstream-name . "metagenomeSeq")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biobase
+           r-foreach
+           r-glmnet
+           r-gplots
+           r-limma
+           r-matrix
+           r-matrixstats
+           r-rcolorbrewer
+           r-wrench))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/HCBravoLab/metagenomeSeq")
+    (synopsis "Statistical analysis for sparse high-throughput sequencing")
+    (description
+     "MetagenomeSeq is designed to determine features (be it @acronym{OTU, Operational
+Taxanomic Unit}, species, etc.) that are differentially abundant between two or
+more groups of multiple samples.  This package is designed to address the effects
+of both normalization and under-sampling of microbial communities on disease
+association detection and the testing of feature correlations.")
+    (license license:artistic2.0)))
+
 (define-public r-metaneighbor
   (package
     (name "r-metaneighbor")