diff mbox series

[bug#61891]

Message ID 20230301072343.708693-4-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61891] | expand

Commit Message

Mădălin Ionel Patrașcu March 1, 2023, 7:23 a.m. UTC
Date: Thu, 23 Feb 2023 01:20:10 +0100
Subject: [PATCH 4/7] gnu: Add r-chemometrics.

* gnu/packages/cran.scm (r-chemometrics): New variable.
---
 gnu/packages/cran.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b3aff2ee2c..fc24f3eafc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17025,6 +17025,44 @@  (define-public r-chemometricswithr
 Life Sciences\" by Ron Wehrens, Springer (2011).")
     (license license:gpl2+)))
 
+(define-public r-chemometrics
+  (package
+    (name "r-chemometrics")
+    (version "1.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "chemometrics" version))
+       (sha256
+        (base32 "0shqns0n964pfwnd0q5sadglrlpgs4g5fbv45fsj9p37l4pq61dp"))))
+    (properties `((upstream-name . "chemometrics")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-class
+           r-e1071
+           r-lars
+           r-mass
+           r-mclust
+           r-nnet
+           r-pcapp
+           r-pls
+           r-robustbase
+           r-rpart
+           r-som))
+    (home-page "http://www.statistik.tuwien.ac.at/public/filz/")
+    (synopsis "Multivariate statistical analysis in Chemometrics")
+    (description
+     "Multivariate data analysis is the simultaneous observation of more than one
+characteristic.  In contrast to the analysis of univariate data, in this approach
+not only a single variable or the relation between two variables can be investigated,
+but the relations between many attributes can be considered.  For the statistical
+analysis of chemical data one has to take into account the special structure of
+this type of data.  This package contains about 30 functions, mostly for regression,
+classification and model evaluation and includes some data sets used in the R help
+examples.  It was designed as a R companion to the book \"Introduction to Multivariate
+Statistical Analysis in Chemometrics\" written by K. Varmuza and P. Filzmoser (2009).")
+    (license license:gpl3+)))
+
 (define-public r-als
   (package
     (name "r-als")