diff mbox series

[bug#61891]

Message ID 20230301072343.708693-3-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61891] | expand

Commit Message

Mădălin Ionel Patrașcu March 1, 2023, 7:23 a.m. UTC
Date: Thu, 23 Feb 2023 00:56:33 +0100
Subject: [PATCH 3/7] gnu: Add r-som.

* gnu/packages/cran.scm (r-som): New variable.
---
 gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ddff93aa0d..b3aff2ee2c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16017,6 +16017,34 @@  (define-public r-softimpute
 components).")
     (license license:gpl2)))
 
+(define-public r-som
+  (package
+    (name "r-som")
+    (version "0.3-5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "som" version))
+       (sha256
+        (base32 "1fbza1jxvwrkf5x3inkj36vshhkn7mz0ajqlxalbfmk6ngjw1x56"))))
+    (properties `((upstream-name . "som")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=som")
+    (synopsis "Self-organizing map")
+    (description
+     "This package implements a self-organizing map which has application in gene
+clustering.  It provides functions like:
+@itemize
+@item filtering data by certain floor, ceiling, max/min ratio, and max - min
+difference;
+@item normalization of the data;
+@item get the average distortion measure;
+@item train a self-organizing map;
+@item summarize a som object;
+@item yeast cell cycle.
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public r-fftwtools
   (package
     (name "r-fftwtools")