diff mbox series

[bug#61891,2/7] gnu: Add r-cplm.

Message ID 20230301072343.708693-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61891,1/7] gnu: Add r-biglm. | expand

Commit Message

Mădălin Ionel Patrașcu March 1, 2023, 7:23 a.m. UTC
* gnu/packages/cran.scm (r-cplm): New variable.
---
 gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fc8fe1a449..ddff93aa0d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -325,6 +325,41 @@  (define-public r-collections
 queues, stacks, deques, dicts and ordered dicts.")
     (license license:expat)))
 
+(define-public r-cplm
+  (package
+    (name "r-cplm")
+    (version "0.7-10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cplm" version))
+       (sha256
+       (base32 "0mqjk10265hq9bc5ihmgbx1l8fzay1gpdlvx3pirqmvr3w1kwlxk"))))
+    (properties `((upstream-name . "cplm")))
+    (build-system r-build-system)
+    (propagated-inputs
+      (list r-biglm
+            r-coda
+            r-ggplot2
+            r-matrix
+            r-minqa
+            r-nlme
+            r-reshape2
+            r-statmod
+            r-tweedie))
+    (home-page "https://github.com/actuaryzhang/cplm")
+    (synopsis "Compound Poisson linear models")
+    (description "The Tweedie compound Poisson distribution is a mixture of a
+degenerate distribution at the origin and a continuous distribution on the positive
+real line.  It has been applied in a wide range of fields in which continuous data
+with exact zeros regularly arise.  The cplm package provides likelihood based and
+Bayesian procedures for fitting common Tweedie compound Poisson linear models.
+In particular, models with hierarchical structures or extra zero inflation can be
+handled.  Further, the package implements the Gini index based on an ordered version
+of the Lorenz curve as a robust model comparison tool involving zero-inflated and
+highly skewed distributions.")
+    (license license:gpl2+)))
+
 (define-public r-curry
   (package
     (name "r-curry")