diff mbox series

[bug#61801,v2] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.02.06

Message ID 20230227063958.17885-1-atai@atai.org
State New
Headers show
Series [bug#61801,v2] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.02.06 | expand

Commit Message

Andy Tai Feb. 27, 2023, 6:39 a.m. UTC
* gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
(opencl-headers): Update to 2023.02.06
(opencl-icd-loader): Update to 2023.02.06
[arguments]: Add configure flag to disable CTest building that
cause errors as tests are meant to be disabled
---
 gnu/packages/opencl.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)


base-commit: cb0d8100b288b5b0d130820207db17764b7d2140

Comments

Leo Famulari Feb. 27, 2023, 9:49 p.m. UTC | #1
To answer your question from another message where you asked how to
describe changes to things like package arguments in the commit
message...

On Sun, Feb 26, 2023 at 10:39:58PM -0800, Andy Tai wrote:
> * gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
> (opencl-headers): Update to 2023.02.06
> (opencl-icd-loader): Update to 2023.02.06
> [arguments]: Add configure flag to disable CTest building that
> cause errors as tests are meant to be disabled

Basically as you've done here, except that the [arguments] portion
should be within the section for the package that it changes.

In this case, you changed the arguments of opencl-clhpp, so you should
list the changes underneath opencl-clhpp's listing in the commit
message.

More generally, our commit messages are in GNU ChangeLog format, which
describes changes at a code level based on variables (i.e. Guix
packages or functions) and the fields within them.

https://www.gnu.org/prep/standards/html_node/Change-Logs.html

For Guix, if I am unsure, I look for similar commits in our Git log. As
always, feel free to ask for help on IRC or the mailing list.

I tweaked the commit message for you and pushed as
dfcf1d5d6a56d0cabeec4836bab1f1f1f063a0e1
diff mbox series

Patch

diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 8cf90698ea..099864dc66 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -54,7 +55,7 @@  (define-module (gnu packages opencl)
 (define-public opencl-headers
   (package
     (name "opencl-headers")
-    (version "2021.06.30")
+    (version "2023.02.06")
     (source
       (origin
         (method git-fetch)
@@ -63,7 +64,7 @@  (define-public opencl-headers
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1nrvx0x9r1nz1qpmzbgffnn9h9pn2fwcxsksf101bkpmqziq5lii"))))
+         (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Not enabled during build.
     (synopsis "The Khronos OpenCL headers")
@@ -95,7 +96,7 @@  (define-public opencl-headers-1.0
 (define-public opencl-clhpp
   (package
     (name "opencl-clhpp")
-    (version "2.0.15")
+    (version "2023.02.06")
     (source
      (origin
        (method git-fetch)
@@ -103,14 +104,15 @@  (define-public opencl-clhpp
              (url "https://github.com/KhronosGroup/OpenCL-CLHPP")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "1wycdbvwbdn7lqdd3sby8471qg2zdisr70218ava6cfvxdsqcp83"))
+        (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
        (file-name (git-file-name name version))))
     (native-inputs
      `(("python" ,python-wrapper)))
     (propagated-inputs
      (list opencl-headers))
     (arguments
-     `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF")
+     `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF"
+     		 "-DBUILD_TESTING=OFF") ;; CTest needs this to be turned off
        ;; The regression tests require a lot more dependencies.
        #:tests? #f))
     (build-system cmake-build-system)
@@ -123,7 +125,7 @@  (define-public opencl-clhpp
 (define-public opencl-icd-loader
   (package
     (name "opencl-icd-loader")
-    (version "2021.06.30")
+    (version "2023.02.06")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -132,7 +134,7 @@  (define-public opencl-icd-loader
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "007ws357n1ijrxal1bf9lwy68p0dz1sm9cfcfnnz5f88iwc9xd6m"))))
+                "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Tests need stub loader setup.
     (native-search-paths