diff mbox series

[bug#61834] gnu: fish: Update to 3.6.0.

Message ID 20230227032233.2733-2-winter@winter.cafe
State New
Headers show
Series [bug#61834] gnu: fish: Update to 3.6.0. | expand

Commit Message

Winter Feb. 27, 2023, 3:22 a.m. UTC
* gnu/packages/shells.scm (fish): Update to 3.6.0.
[source]: Remove snippet, as the vendored PCRE2 sources have been
removed (see upstream changelog).
---
 gnu/packages/shells.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)


base-commit: 81fbf5d71fb95367a0a93e45a86de5e930589a05

Comments

Tobias Geerinckx-Rice March 2, 2023, 11:57 p.m. UTC | #1
Winter,

Winter via Guix-patches via 写道:
> * gnu/packages/shells.scm (fish): Update to 3.6.0.

Thanks!  Pushed as ea870a70e93e7ea93e35fa8e0afc3cfdb1b66ba2, with 
only slight edits:

> [source]: Remove snippet, as the vendored PCRE2 sources have 
> been

I boldly s/vendored/bundled/ :-)

> removed (see upstream changelog).

I wrote ‘CHANGELOG.rst’ here to make it (more) clear that it's a 
file in the sourceball.

> +       (modules '((guix build utils)))))

The only purpose of this source field is to make modules available 
to snippets, so it can go too.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 0c8cbf3f4c..f550a2c943 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -118,7 +118,7 @@  (define-public dash
 (define-public fish
   (package
     (name "fish")
-    (version "3.5.1")
+    (version "3.6.0")
     (source
      (origin
        (method url-fetch)
@@ -126,15 +126,11 @@  (define-public fish
                            "releases/download/" version "/"
                            "fish-" version ".tar.xz"))
        (sha256
-        (base32 "0a39vf0wqq6asw5xcrwgdsc67h5bxkgxzy77f8bx6pd4qlympm56"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Remove bundled software.
-           (delete-file-recursively "pcre2")))))
+        (base32 "10b1xa1hpmi62rzh3qgxlw7xrhyigs8kssagccawmrryfxbls14p"))
+       (modules '((guix build utils)))))
     (build-system cmake-build-system)
     (inputs
-     (list fish-foreign-env ncurses pcre2 ; don't use the bundled PCRE2
+     (list fish-foreign-env ncurses pcre2
            python))  ; for fish_config and manpage completions
     (native-inputs
      (list doxygen groff ; for 'fish --help'