diff mbox series

[bug#61773,1/3] gnu: Add go-golang.org-x-sync-semaphore.

Message ID 20230226191321.13521-2-guix@twilken.net
State New
Headers show
Series gnu: Add actionlint. | expand

Commit Message

Timo Wilken Feb. 26, 2023, 7:13 p.m. UTC
* gnu/packages/golang.scm (go-golang.org-x-sync-semaphore):
  New variable.
---
 gnu/packages/golang.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c4b6bcd874..7268b661cf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7409,6 +7410,17 @@  (define-public go-golang.org-x-sync-errgroup
       (home-page "https://godoc.org/golang.org/x/sync/errgroup")
       (license license:bsd-3))))
 
+(define-public go-golang.org-x-sync-semaphore
+  (package
+    (inherit go-golang.org-x-sync-errgroup)
+    (name "go-golang.org-x-sync-semaphore")
+    (arguments
+     '(#:import-path "golang.org/x/sync/semaphore"
+       #:unpack-path "golang.org/x/sync"))
+    (synopsis "Weighted semaphore implementation in Go")
+    (description "Weighted semaphore implementation in Go.")
+    (home-page "https://godoc.org/golang.org/x/sync/semaphore")))
+
 (define (go-gotest-tools-source version sha256-base32-hash)
   (origin
     (method git-fetch)