diff mbox series

[bug#61801] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.02.06

Message ID 20230226082806.11291-1-atai@atai.org
State New
Headers show
Series [bug#61801] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.02.06 | expand

Commit Message

Andy Tai Feb. 26, 2023, 8:28 a.m. UTC
* gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
(opencl-headers): Update to 2023.02.06
(opencl-icd-loader): Update to 2023.02.06
---
 gnu/packages/opencl.scm | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)


base-commit: cb0d8100b288b5b0d130820207db17764b7d2140

Comments

Leo Famulari Feb. 26, 2023, 5:42 p.m. UTC | #1
On Sun, Feb 26, 2023 at 12:28:06AM -0800, Andy Tai wrote:
> * gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
> (opencl-headers): Update to 2023.02.06
> (opencl-icd-loader): Update to 2023.02.06

Thanks!

Is it correct to assume that these packages should be updated in the
same commit. That is, if they are updated one at a time, will the suite
of software be broken on each commit, until they are all updated?
Andy Tai Feb. 26, 2023, 7:50 p.m. UTC | #2
There is a comment in the current source requiring the three to be
updated in lock step

On Sun, Feb 26, 2023 at 9:42 AM Leo Famulari <leo@famulari.name> wrote:
>
> On Sun, Feb 26, 2023 at 12:28:06AM -0800, Andy Tai wrote:
> > * gnu/packages/opencl.scm (opencl-clhpp): Update to 2023.02.06
> > (opencl-headers): Update to 2023.02.06
> > (opencl-icd-loader): Update to 2023.02.06
>
> Thanks!
>
> Is it correct to assume that these packages should be updated in the
> same commit. That is, if they are updated one at a time, will the suite
> of software be broken on each commit, until they are all updated?
Leo Famulari Feb. 26, 2023, 8:40 p.m. UTC | #3
On Sun, Feb 26, 2023 at 11:50:06AM -0800, Andy Tai wrote:
> There is a comment in the current source requiring the three to be
> updated in lock step

Okay.

Also, the commit message mentions neither the addition of ruby to the
dependencies of opencl-clhpp, nor the BUILD_TESTING flag. Did you mean
to include those changes?

Using diffoscope, I compared the build output with and without ruby, and
they are identical aside from the store paths, so we should leave ruby
out, in any case.
Andy Tai Feb. 26, 2023, 11:07 p.m. UTC | #4
Are there any guidelines on how the commit messages should be written
in regard to these changes?

I will remove the ruby part from the change.

On Sun, Feb 26, 2023 at 12:40 PM Leo Famulari <leo@famulari.name> wrote:
>
> On Sun, Feb 26, 2023 at 11:50:06AM -0800, Andy Tai wrote:
> > There is a comment in the current source requiring the three to be
> > updated in lock step
>
> Okay.
>
> Also, the commit message mentions neither the addition of ruby to the
> dependencies of opencl-clhpp, nor the BUILD_TESTING flag. Did you mean
> to include those changes?
>
> Using diffoscope, I compared the build output with and without ruby, and
> they are identical aside from the store paths, so we should leave ruby
> out, in any case.
diff mbox series

Patch

diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 8cf90698ea..2e4297217a 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -54,7 +55,7 @@  (define-module (gnu packages opencl)
 (define-public opencl-headers
   (package
     (name "opencl-headers")
-    (version "2021.06.30")
+    (version "2023.02.06")
     (source
       (origin
         (method git-fetch)
@@ -63,7 +64,7 @@  (define-public opencl-headers
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1nrvx0x9r1nz1qpmzbgffnn9h9pn2fwcxsksf101bkpmqziq5lii"))))
+         (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Not enabled during build.
     (synopsis "The Khronos OpenCL headers")
@@ -95,7 +96,7 @@  (define-public opencl-headers-1.0
 (define-public opencl-clhpp
   (package
     (name "opencl-clhpp")
-    (version "2.0.15")
+    (version "2023.02.06")
     (source
      (origin
        (method git-fetch)
@@ -103,14 +104,16 @@  (define-public opencl-clhpp
              (url "https://github.com/KhronosGroup/OpenCL-CLHPP")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "1wycdbvwbdn7lqdd3sby8471qg2zdisr70218ava6cfvxdsqcp83"))
+        (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
        (file-name (git-file-name name version))))
     (native-inputs
-     `(("python" ,python-wrapper)))
+     `(("python" ,python-wrapper)
+       ("ruby" ,ruby)))
     (propagated-inputs
      (list opencl-headers))
     (arguments
-     `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF")
+     `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF"
+     		 "-DBUILD_TESTING=OFF") ;; CTest needs this to be turned off
        ;; The regression tests require a lot more dependencies.
        #:tests? #f))
     (build-system cmake-build-system)
@@ -123,7 +126,7 @@  (define-public opencl-clhpp
 (define-public opencl-icd-loader
   (package
     (name "opencl-icd-loader")
-    (version "2021.06.30")
+    (version "2023.02.06")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -132,7 +135,7 @@  (define-public opencl-icd-loader
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "007ws357n1ijrxal1bf9lwy68p0dz1sm9cfcfnnz5f88iwc9xd6m"))))
+                "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Tests need stub loader setup.
     (native-search-paths