diff mbox series

[bug#61674,4/4] gnu: stellarium: Enable ShowMySky.

Message ID 20230226004406.6215-4-sharlatanus@gmail.com
State New
Headers show
Series [bug#61674,1/4] gnu: Add calcmysky. | expand

Commit Message

Sharlatan Hellseher Feb. 26, 2023, 12:44 a.m. UTC
* gnu/packages/astronomy.scm (stellarium):
  [arguments]<#:configure-flags>: Enable ShowMySky optional dependencies
  to simulate scattering of light by the atmosphere.
  [inputs]: Replace QXLSX to QXLSX-QT5. Add CALCMYSKY-QT5.
---
 gnu/packages/astronomy.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès Feb. 27, 2023, 9:15 p.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> * gnu/packages/astronomy.scm (stellarium):
>   [arguments]<#:configure-flags>: Enable ShowMySky optional dependencies
>   to simulate scattering of light by the atmosphere.
>   [inputs]: Replace QXLSX to QXLSX-QT5. Add CALCMYSKY-QT5.

LGTM!

Could you send an updated revision of this patch series taking into
account previous comments?  Then we should be all set!

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0f3176bc3e..ffce19e8fc 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -919,8 +919,6 @@  (define-public stellarium
       #~(list "-DENABLE_GPS=1"
               ;; TODO: Enable when all of the dependencies are availalbe for Qt6.
               "-DENABLE_QT6=0"
-              ;; TODO: Pack missing in Guix https://10110111.github.io/CalcMySky/
-              "-DENABLE_SHOWMYSKY=0"
               "-DENABLE_TESTING=0"
               (string-append "-DCMAKE_CXX_FLAGS=-isystem "
                              #$(this-package-input "qtserialport") "/include/qt5"))
@@ -931,7 +929,8 @@  (define-public stellarium
               (setenv "QT_QPA_PLATFORM" "offscreen")
               (setenv "HOME" "/tmp"))))))
     (inputs
-     (list gpsd
+     (list calcmysky-qt5
+           gpsd
            indi
            libnova
            openssl
@@ -944,7 +943,7 @@  (define-public stellarium
            qtserialport
            qttranslations
            qtwebengine-5
-           qxlsx
+           qxlsx-qt5
            zlib))
     (native-inputs
      (list doxygen