diff mbox series

[bug#61792] gnu: ffmpeg: enable libwebp

Message ID 20230225195646.16297-1-ryan@arctype.co
State New
Headers show
Series [bug#61792] gnu: ffmpeg: enable libwebp | expand

Commit Message

Ryan Sundberg Feb. 25, 2023, 7:56 p.m. UTC
* gnu/packages/video.scm (ffmpeg)[configure-flags]: --enable-libwebp

Signed-off-by: Ryan Sundberg <ryan@arctype.co>
---
 gnu/packages/video.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Leo Famulari Feb. 26, 2023, 2:53 a.m. UTC | #1
On Sat, Feb 25, 2023 at 11:56:46AM -0800, Ryan Sundberg via Guix-patches via wrote:
> * gnu/packages/video.scm (ffmpeg)[configure-flags]: --enable-libwebp

Thanks!

Did you test if all the versions of FFmpeg that are packaged in Guix
support libwebp? Or is it only FFmpeg 5.1?

If you look in gnu/packages/video.scm, you'll see several other versions
that inherit from ffmpeg-5.
Leo Famulari March 2, 2023, 4:02 a.m. UTC | #2
On Wed, Mar 01, 2023 at 12:13:37AM -0800, Ryan Sundberg wrote:
> Surprisingly, this flag is supported all the way back to ffmpeg-3. So I
> tested guix shell ffmpeg@5 ffmpeg@4 ffmpeg@3 and ffmpeg@2 (which clears
> all configure flags), all builds passed.

Great! I removed the input from ffmpeg-2.8, since it wouldn't have been
used anyways (although it is supported), and pushed as
03b463b68ba62b0b6f11a585240829fddef37f48
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f63d5494de..f64608d18a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1634,6 +1634,7 @@  (define-public ffmpeg-5
             libvdpau
             libvorbis
             libvpx
+            libwebp
             libx11
             libx264
             mesa
@@ -1731,6 +1732,7 @@  (define-public ffmpeg-5
          "--enable-libvidstab"
          "--enable-libvorbis"
          "--enable-libvpx"
+         "--enable-libwebp"
          "--enable-libxvid"
          "--enable-libx264"
          "--enable-libx265"