diff mbox series

[bug#61775,2/2] gnu: Add zsh-completions

Message ID 20230224230524.31292-2-guix@twilken.net
State New
Headers show
Series Add zsh shell niceties | expand

Commit Message

Timo Wilken Feb. 24, 2023, 11:05 p.m. UTC
* gnu/packages/shellutils.scm (zsh-completions): New variable.
---
 gnu/packages/shellutils.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 3553eaa4ed..4a2917cfa2 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -222,6 +222,32 @@  (define-public zsh-autosuggestions
 as you type.")
     (license license:expat)))
 
+(define-public zsh-completions
+  (package
+    (name "zsh-completions")
+    (version "0.34.0")
+    (home-page "https://github.com/zsh-users/zsh-completions")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jjgvzj3v31yibjmq50s80s3sqi4d91yin45pvn3fpnihcrinam9"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan '(("src/" "share/zsh/site-functions/")
+                        ("README.md" "share/doc/zsh-completions/"))))
+    (synopsis "Additional completion definitions for Zsh")
+    (description
+     "This projects aims at gathering/developing new completion scripts that
+are not available in Zsh yet.  The scripts may be contributed to the Zsh
+project when stable enough.")
+    (license (license:non-copyleft "file://LICENSE"
+              "Custom BSD-like, permissive, non-copyleft license."))))
+
 (define-public zsh-history-substring-search
   (package
     (name "zsh-history-substring-search")