diff mbox series

[bug#61756,5/8] gnu: Add emacs-xcscope.

Message ID 20230224141819.12675-5-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#61753,1/8] gnu: Add emacs-font-lock+. | expand

Commit Message

Rostislav Svoboda Feb. 24, 2023, 2:18 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou March 8, 2023, 3:42 p.m. UTC | #1
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> +(define-public emacs-xcscope

Thank you. Some comments follow.

> +  (package

You need to let-bind commit and revision (set to "0" initially) around
here.

> +    (name "emacs-xcscope")
> +    (version "1.0")

Here, you should use

  (git-version "1.0" revision commit)

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/dkogan/xcscope.el")
> +             (commit "d228d7593d762e457340f678d14b663ef66d7cee")))

This should be

  (commit commit)

> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0pr85ywp585imjzswm04647nb4iqqvg8jgmbcs5210qmr9kh0z8d"))))
> +    (build-system emacs-build-system)

You also need to add `cscope' as an input, and patch "xscope.el" so
`cscope-program' point to the proper binary, using
`emacs-substitute-variables'. See, e.g., emacs-plz package for an
example.

> +    (home-page "https://github.com/dkogan/xcscope.el")
> +    (synopsis "cscope interface for (X)Emacs")

cscope -> Cscope. You can also drop (X) from (X)Emacs.

> +    (description
> +     "cscope interface for (X)Emacs")

This should be a full sentence (with proper capitalization).

> +    (license license:gpl3+)))

License is actually license:gpl2+, per headers in xscope.el file.

>  ;;; Avoid adding new packages to the end of this file. To reduce the chances
>  ;;; of a merge conflict, place them above by existing packages with similar

  ^
  Hmmmmm…

Could you send an updated patch, with another location for the package
definition, and a proper commit message?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a024ddec6a..b444ab0da0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36086,6 +36086,26 @@  (define-public emacs-vertico-posframe
 a vertical completion UI.")
     (license license:gpl3+)))
 
+(define-public emacs-xcscope
+  (package
+    (name "emacs-xcscope")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dkogan/xcscope.el")
+             (commit "d228d7593d762e457340f678d14b663ef66d7cee")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0pr85ywp585imjzswm04647nb4iqqvg8jgmbcs5210qmr9kh0z8d"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/dkogan/xcscope.el")
+    (synopsis "cscope interface for (X)Emacs")
+    (description
+     "cscope interface for (X)Emacs")
+    (license license:gpl3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar