diff mbox series

[bug#61754,3/8] gnu: Add emacs-ac-ispell.

Message ID 20230224141819.12675-3-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#61753,1/8] gnu: Add emacs-font-lock+. | expand

Commit Message

Rostislav Svoboda Feb. 24, 2023, 2:18 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Nicolas Goaziou March 8, 2023, 3:34 p.m. UTC | #1
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> +(define-public emacs-ac-ispell

Thanks. I applied it with usual changes already explained (let-binding
commit, full sentences in description…).

I also used proper capitalization in description.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 54aad0bf7b..e71636b2a9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -264,6 +264,27 @@  (define-module (gnu packages emacs-xyz)
 ;;; Emacs hacking.
 ;;;
 
+(define-public emacs-ac-ispell
+  (package
+    (name "emacs-ac-ispell")
+    (version "0.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emacsorphanage/ac-ispell")
+             (commit "22bace7387e9012002a6a444922f75f9913077b0")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1cq73bdv3lkn8v3nx6aznygqaac9s5i7pvirl8wz9ib31hsgwpbk"))))
+    (build-system emacs-build-system)
+    (inputs (list emacs-auto-complete))
+    (home-page "https://github.com/emacsorphanage/ac-ispell")
+    (synopsis "ispell/aspell completion source for auto-complete")
+    (description
+     "ispell/aspell completion source for auto-complete")
+    (license license:gpl3+)))
+
 (define-public emacs-cfrs
   (package
     (name "emacs-cfrs")