diff mbox series

[bug#61752,2/8] gnu: Add emacs-cfrs.

Message ID 20230224141819.12675-2-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#61753,1/8] gnu: Add emacs-font-lock+. | expand

Commit Message

Rostislav Svoboda Feb. 24, 2023, 2:18 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Nicolas Goaziou March 8, 2023, 3:33 p.m. UTC | #1
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> ---
> +(define-public emacs-cfrs

Thank you. I applied your patch with a proper commit message.

> +  (package
> +    (name "emacs-cfrs")
> +    (version "1.6.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/Alexander-Miller/cfrs")
> +             (commit "f3a21f237b2a54e6b9f8a420a9da42b4f0a63121")))

We don't put raw commit hashes here. We either use a tag, or let-bind it
to `commit' symbol around the whole package definition. See
emacs-xyz.scm for a truck load of examples.

> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1vf5zm82sx3m1yvq73km8ajapv6rnz41b1jrsif7kh0ijh9vk3qi"))))
> +    (build-system emacs-build-system)
> +    (inputs (list

Indentation is off here (newline missing before "(list"). Also, Emacs inputs are actually propagated
inputs.

> +      emacs-s
> +      emacs-dash
> +      emacs-posframe))

I re-ordered inputs alphabetically.

> +    (home-page "https://github.com/Alexander-Miller/cfrs")
> +    (synopsis "Child Frame Read String")
> +    (description
> +     "Simple alternative to read-string that allows reading input via a small

I turned this into a full sentence.

> +child-frame spawned at the position of the cursor. Its goal is to make the

Note: Texinfo requires two spaces after full stops.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a3103ac3d4..54aad0bf7b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -264,6 +264,34 @@  (define-module (gnu packages emacs-xyz)
 ;;; Emacs hacking.
 ;;;
 
+(define-public emacs-cfrs
+  (package
+    (name "emacs-cfrs")
+    (version "1.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Alexander-Miller/cfrs")
+             (commit "f3a21f237b2a54e6b9f8a420a9da42b4f0a63121")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vf5zm82sx3m1yvq73km8ajapv6rnz41b1jrsif7kh0ijh9vk3qi"))))
+    (build-system emacs-build-system)
+    (inputs (list
+      emacs-s
+      emacs-dash
+      emacs-posframe))
+    (home-page "https://github.com/Alexander-Miller/cfrs")
+    (synopsis "Child Frame Read String")
+    (description
+     "Simple alternative to read-string that allows reading input via a small
+child-frame spawned at the position of the cursor. Its goal is to make the
+string input interface closer to those used in modern GUI programs and to help
+the user with having to switch focus from whatever they are doing currently to
+look at the minibuffer.")
+    (license license:gpl3+)))
+
 (define-public emacs-geiser
   (package
     (name "emacs-geiser")