diff mbox series

[bug#61751,2/2] gnu: dos2unix: Use new package style.

Message ID 20230224141524.3897-2-timotej.lazar@araneo.si
State New
Headers show
Series Update dos2unix | expand

Commit Message

Timotej Lazar Feb. 24, 2023, 2:15 p.m. UTC
* gnu/packages/textutils.scm (dos2unix)[arguments]: Use gexps.
[native-inputs]: Drop labels.
---
 gnu/packages/textutils.scm | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 9efcda688b..e5d3a0efc0 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -89,15 +89,14 @@  (define-public dos2unix
         (base32 "0vj3wix17vl7a85hg673qqyrhw9sbq0xiadbbij7v0nm1gdl3a18"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
-       (list (string-append "CC=" ,(cc-for-target))
-             (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)))) ; no configure script
+     (list #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "prefix=" #$output))
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)))) ; no configure script
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("perl" ,perl)))
+     (list gettext-minimal perl))
     (home-page "https://waterlan.home.xs4all.nl/dos2unix.html")
     (synopsis "DOS/Mac to Unix and vice versa text file format converter")
     (description