diff mbox series

[bug#61747] gnu: r-dofuture: Fix the check warnings.

Message ID 20230224064020.5316-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61747] gnu: r-dofuture: Fix the check warnings. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 24, 2023, 6:40 a.m. UTC
* gnu/packages/cran.scm (r-dofuture): Fix the check warnings.
[propagated-inputs]: Rearrangement of the in inputs in the column way.
[native-inputs]: Add r-markdown for the check phase.
---
 gnu/packages/cran.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)


base-commit: 31735e0ccfbc61905eb8558c14747bfcaea9b50f

Comments

Ricardo Wurmus Oct. 4, 2023, 9:33 a.m. UTC | #1
Pushed a variant of this with commit
5f2704517c83e2bd3fbe5d4410531a0ba3ea4461.

I only kept the addition of r-markdown.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c7a81b96eb..17301e3469 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12776,9 +12776,13 @@  (define-public r-dofuture
          (add-after 'unpack 'set-HOME
            (lambda _ (setenv "HOME" "/tmp"))))))
     (propagated-inputs
-     (list r-foreach r-future r-globals r-iterators))
+     (list r-foreach
+           r-future
+           r-globals
+           r-iterators))
     (native-inputs
-     (list r-r-rsp)) ; vignette builder
+     (list r-markdown  ; check phase requires markdown package
+           r-r-rsp))   ; vignette builder
     (home-page "https://github.com/HenrikBengtsson/doFuture")
     (synopsis "Foreach parallel adapter using the future API")
     (description