diff mbox series

[bug#61665] gnu: python-clingo: Fix invalid G-expression input.

Message ID 20230221010018.2689405-1-zimon.toutoune@gmail.com
State New
Headers show
Series [bug#61665] gnu: python-clingo: Fix invalid G-expression input. | expand

Commit Message

Simon Tournier Feb. 21, 2023, 1 a.m. UTC
* gnu/packages/maths.scm (python-clingo)[arguments]: Add 'imported-modules'
and 'modules' in order to access to 'python:site-packages'.
[version]: Explicitly reuse from the package 'clingo'.
---

Hi,

This package seems broken:

--8<---------------cut here---------------start------------->8---
$ guix time-machine --commit=e8fcf1e424 -- build python-clingo
guix build: erreur : #<procedure version ()> : entrée G-expression invalide
--8<---------------cut here---------------end--------------->8---

The issue seems coming from the field 'version'.  Then, commit
8285093cee000d6e28c040f721ddf0be18d32c42 introduces #$version which introduces
the failure.

Well, I have not found the correct G-exp syntax for #:imported-modules.

Cheers,
simon


 gnu/packages/maths.scm | 8 ++++++++
 1 file changed, 8 insertions(+)


base-commit: e8fcf1e42438113d7e4be82dc5a06de45eaceb76

Comments

Liliana Marie Prikler Feb. 21, 2023, 5:31 a.m. UTC | #1
Am Dienstag, dem 21.02.2023 um 02:00 +0100 schrieb Simon Tournier:
> * gnu/packages/maths.scm (python-clingo)[arguments]: Add 'imported-
> modules'
> and 'modules' in order to access to 'python:site-packages'.
> [version]: Explicitly reuse from the package 'clingo'.
> ---
> 
> Hi,
> 
> This package seems broken:
> 
> --8<---------------cut here---------------start------------->8---
> $ guix time-machine --commit=e8fcf1e424 -- build python-clingo
> guix build: erreur : #<procedure version ()> : entrée G-expression
> invalide
> --8<---------------cut here---------------end--------------->8---
> 
> The issue seems coming from the field 'version'.  Then, commit
> 8285093cee000d6e28c040f721ddf0be18d32c42 introduces #$version which
> introduces the failure.
Thanks.

> Well, I have not found the correct G-exp syntax for #:imported-
> modules.
Quoting works fine.

> 
>  gnu/packages/maths.scm | 8 ++++++++
>  1 file changed, 8 insertions(+)
> 
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 1e40be8722..67634990ae 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -2703,12 +2703,20 @@ (define-public python-clingo
>    (package
>      (inherit clingo)
>      (name "python-clingo")
> +    (version (package-version clingo)) ;Fix error: invalid G-
> expression #$version
Reworded slightly and pushed (it's a hotfix and CI succeeds).

Cheers
Christopher Baines Feb. 21, 2023, 12:52 p.m. UTC | #2
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

>>  gnu/packages/maths.scm | 8 ++++++++
>>  1 file changed, 8 insertions(+)
>> 
>> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
>> index 1e40be8722..67634990ae 100644
>> --- a/gnu/packages/maths.scm
>> +++ b/gnu/packages/maths.scm
>> @@ -2703,12 +2703,20 @@ (define-public python-clingo
>>    (package
>>      (inherit clingo)
>>      (name "python-clingo")
>> +    (version (package-version clingo)) ;Fix error: invalid G-
>> expression #$version
> Reworded slightly and pushed (it's a hotfix and CI succeeds).

Closing accordingly.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1e40be8722..67634990ae 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2703,12 +2703,20 @@  (define-public python-clingo
   (package
     (inherit clingo)
     (name "python-clingo")
+    (version (package-version clingo)) ;Fix error: invalid G-expression #$version
     (arguments
      (substitute-keyword-arguments (package-arguments clingo)
        ((#:configure-flags flags #~'())
         #~(cons* "-DCLINGO_BUILD_WITH_PYTHON=pip"
                  "-DCLINGO_USE_LIB=yes"
                  #$flags))
+       ((#:imported-modules _ '())
+        `(,@%cmake-build-system-modules
+          (guix build python-build-system)))
+       ((#:modules _ '())
+        '((guix build cmake-build-system)
+          ((guix build python-build-system) #:prefix python:)
+          (guix build utils)))
        ((#:phases phases #~%standard-phases)
         #~(modify-phases #$phases
             (add-after 'unpack 'fix-failing-tests