diff mbox series

[bug#61650] qtwebengine-5: Enable pulseaudio.

Message ID 20230220122022.810-1-iyzsong@member.fsf.org
State New
Headers show
Series [bug#61650] qtwebengine-5: Enable pulseaudio. | expand

Commit Message

宋文武 Feb. 20, 2023, 12:20 p.m. UTC
Previously it will dlopen libpulse, then fallback to alsa.
See also <https://issues.guix.gnu.org/45280>.

* gnu/packages/qt.scm (qtwebengine-5)[arguments]: Set link_pulseaudio with gn_args.
---
 gnu/packages/qt.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: 53e27f8abf1163e29fb5fc17af38b90a67a18138

Comments

宋文武 Feb. 22, 2023, 1:43 a.m. UTC | #1
宋文武 <iyzsong@member.fsf.org> writes:

> Previously it will dlopen libpulse, then fallback to alsa.
> See also <https://issues.guix.gnu.org/45280>.
>
> * gnu/packages/qt.scm (qtwebengine-5)[arguments]: Set link_pulseaudio with gn_args.

QA successed, pushed now!
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b32a78085d..3efe3961cf 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2669,7 +2669,8 @@  (define-public qtwebengine-5
                   "src/buildtools/config/linux.pri"
                   (lambda (in out)
                     (display (get-string-all in) out)
-                    (display "\ngn_args += use_system_openh264=true\n" out)))
+                    (display "\ngn_args += use_system_openh264=true\n" out)
+                    (display "\ngn_args += link_pulseaudio = true\n" out)))
                  ;; Qtwebengine is not installed into the same prefix as
                  ;; qtbase.  Some qtbase QTLibraryInfo constants will not
                  ;; work.  Replace with the full path to the qtwebengine-5