diff mbox series

[bug#61593] gnu: ableton-link: Update to 3.0.6.

Message ID 20230218044700.7559-1-antero@mailbox.org
State New
Headers show
Series [bug#61593] gnu: ableton-link: Update to 3.0.6. | expand

Commit Message

Antero Mejr Feb. 18, 2023, 4:47 a.m. UTC
* gnu/packages/audio.scm (ableton-link): Update to 3.0.6.
* gnu/packages/patches/ableton-link-system-libraries-debian.patch: Update to
match version 3.0.6.
---
Includes the new C bindings that are required for norns, which I am packaging.

 gnu/packages/audio.scm                                 | 10 +++++++---
 .../patches/ableton-link-system-libraries-debian.patch |  2 +-
 2 files changed, 8 insertions(+), 4 deletions(-)

Comments

Christopher Baines March 2, 2023, 9:46 a.m. UTC | #1
Antero Mejr via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/audio.scm (ableton-link): Update to 3.0.6.
> * gnu/packages/patches/ableton-link-system-libraries-debian.patch: Update to
> match version 3.0.6.
> ---
> Includes the new C bindings that are required for norns, which I am packaging.
>
>  gnu/packages/audio.scm                                 | 10 +++++++---
>  .../patches/ableton-link-system-libraries-debian.patch |  2 +-
>  2 files changed, 8 insertions(+), 4 deletions(-)

Hi Antero,

This looks to break ableton-link on aarch64-linux:
https://qa.guix.gnu.org/issue/61593

This is the log:

starting phase `check'
['/tmp/guix-build-ableton-link-3.0.6.drv-0/source/ci/../../build/bin/LinkCoreTest']
Running Tests for LinkCoreTest

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
LinkCoreTest is a Catch v1.3.5 host application.
Run with -? for options

-------------------------------------------------------------------------------
LinearRegression
  TwoPoints Float
-------------------------------------------------------------------------------
/tmp/guix-build-ableton-link-3.0.6.drv-0/source/src/ableton/link/tst_LinearRegression.cpp:30
...............................................................................

/tmp/guix-build-ableton-link-3.0.6.drv-0/source/src/ableton/link/tst_LinearRegression.cpp:80: FAILED:
  CHECK( 0.f == Approx(result.second) )
with expansion:
  0.0f == Approx( -0.0011631348 )

===============================================================================
test cases:     14 |     13 passed | 1 failed
assertions: 524519 | 524518 passed | 1 failed

error: in phase 'check': uncaught exception:
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6504ec2345..ba90152981 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5706,7 +5706,7 @@  (define-public mbelib
 (define-public ableton-link
   (package
     (name "ableton-link")
-    (version "3.0.3")
+    (version "3.0.6")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5715,7 +5715,7 @@  (define-public ableton-link
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1wplqj11ww64gmw2kzlxpvfs3v04m2036f7k5ndm34zcv12b91fa"))
+                "140nxqgl50jjwilm9c2r15lyg6k0k38phlcz8kw2i8hpza924wjg"))
               (modules '((guix build utils)))
               (patches
                (search-patches "ableton-link-system-libraries-debian.patch"))
@@ -5786,7 +5786,11 @@  (define-public ableton-link
                              lib-cmake)
                (install-file (string-append source
                                             "/cmake_include/AsioStandaloneConfig.cmake")
-                             (string-append lib-cmake "/cmake_include"))))))))
+                             (string-append lib-cmake "/cmake_include"))
+               (install-file
+                (string-append source "/extensions/abl_link/include/abl_link.h")
+                (string-append out "/include/extensions/abl_link"))
+               (install-file "libabl_link.a" (string-append out "/lib"))))))))
     (home-page "https://github.com/Ableton/link")
     (synopsis "Synchronize musical beat, tempo, and phase across multiple applications")
     (description
diff --git a/gnu/packages/patches/ableton-link-system-libraries-debian.patch b/gnu/packages/patches/ableton-link-system-libraries-debian.patch
index 184896ee61..5717e77f0e 100644
--- a/gnu/packages/patches/ableton-link-system-libraries-debian.patch
+++ b/gnu/packages/patches/ableton-link-system-libraries-debian.patch
@@ -25,5 +25,5 @@  This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
  
 -set_property(TARGET Catch::Catch APPEND PROPERTY
 -  INTERFACE_INCLUDE_DIRECTORIES
--  ${CMAKE_SOURCE_DIR}/third_party/catch
+-  ${CMAKE_CURRENT_LIST_DIR}/../third_party/catch
 -)