diff mbox series

[bug#61551] gnu: Add r-changepoint.

Message ID 20230216154523.20036-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61551] gnu: Add r-changepoint. | expand

Commit Message

nafkhamdc Feb. 16, 2023, 3:45 p.m. UTC
* gnu/packages/cran.scm (r-changepoint): New variable.
---
 gnu/packages/cran.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Ricardo Wurmus Feb. 16, 2023, 5:54 p.m. UTC | #1
Thanks for the patch!  Applied with minor changes (line breaks and a
license comment).
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b4dc7822f2..857026a573 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -283,6 +283,27 @@  (define-public r-castor
 reading/writing trees in Newick format.")
     (license license:gpl2+)))
 
+(define-public r-changepoint
+  (package
+    (name "r-changepoint")
+    (version "2.2.4")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "changepoint" version))
+              (sha256
+               (base32
+                "16v4p2c9zi2w3anwf5y9snl5dy1g5aidiqz1vn2p64qhfvg6yqxc"))))
+    (properties `((upstream-name . "changepoint")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-zoo))
+    (home-page "https://github.com/rkillick/changepoint/")
+    (synopsis "Methods for changepoint detection")
+    (description
+     "Changepoint implements various mainstream and specialised changepoint methods.
+These Methods are suitable for finding single and multiple changepoints within data.
+Many popular non-parametric and frequentist methods are included as well.")
+    (license license:gpl3+)))
+
 (define-public r-collections
   (package
     (name "r-collections")