diff mbox series

[bug#60673,v2,14/39] gnu: Add aliases for ocaml-cstruct and ocaml-lwt subpackages.

Message ID 20230215220028.18575-15-raingloom@riseup.net
State New
Headers show
Series [bug#60673,v2,01/39] gnu: Add ocaml-domain-name. | expand

Commit Message

Csepp Feb. 15, 2023, 10 p.m. UTC
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-lwt-ppx ocaml-cstruct-unix
  ocaml-cstruct-sexp): New variables.
---
 gnu/packages/ocaml.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index affd0c194a..552759a171 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2963,6 +2963,11 @@  (define-public ocaml-lwt
 locks or other synchronization primitives.")
     (license license:lgpl2.1)))
 
+;; TODO this alias is not ideal but ocaml-lwt already explicitly specifies a
+;; package argument and at least this way the importer doesn't try to
+;; re-import it.
+(define ocaml-lwt-ppx ocaml-lwt)
+
 (define-public ocaml-lwt-dllist
   (package
     (name "ocaml-lwt-dllist")
@@ -4453,6 +4458,12 @@  (define-public ocaml4.07-cstruct
                   "0jj3whs8r3jc524i9bb67rffh7y7r157hjgvws0bkxijxpjzwkbk"))))
       (properties '()))))
 
+;; TODO again, the "parent" package already has an explicit package argument,
+;; so a variant package doesn't make sense, at least these aliases help the
+;; importer out so it doesn't re-import things.  At least hopefully.
+(define ocaml-cstruct-unix ocaml-cstruct)
+(define ocaml-cstruct-sexp ocaml-cstruct)
+
 (define-public ocaml-hex
   (package
     (name "ocaml-hex")