diff mbox series

[bug#61473,1/3] gnu: Add rust-protobuf. * gnu/packages/crates-io.scm (rust-protobuf-2): New variable.

Message ID 20230213111757.692759-1-steve@futurile.net
State New
Headers show
Series [bug#61473,1/3] gnu: Add rust-protobuf. * gnu/packages/crates-io.scm (rust-protobuf-2): New variable. | expand

Commit Message

Steve George Feb. 13, 2023, 11:17 a.m. UTC
---

 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Efraim Flashner Feb. 14, 2023, 3:06 p.m. UTC | #1
Thanks. I fixed up the commit messages (the lines got squashed together)
and expanded the descriptions.

Patches pushed!
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 80f7e619bb..cd4ca8c48d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -43149,6 +43149,31 @@  (define-public rust-prost-0.9
 language.")
     (license license:asl2.0)))
 
+;; It's recommended that rust-protobuf, rust-protobuf-codegen
+;; and rust-probuf-codegen-pure be the same version
+(define-public rust-protobuf-2
+  (package
+    (name "rust-protobuf")
+    (version "2.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "protobuf" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "11bl8hf522s9mbkckivnn9n8s3ss4g41w6jmfdsswmr5adqd71lf"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ;missing files?
+       #:skip-build? #f
+       #:cargo-inputs (("rust-bytes" ,rust-bytes-0.5)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-derive" ,rust-serde-derive-1))))
+    (home-page "https://github.com/stepancheg/rust-protobuf/")
+    (synopsis "Rust implementation of Google protocol buffers")
+    (description "Library to read and write protocol buffer's data.")
+    (license license:expat)))
+
 (define-public rust-psl-2
   (package
     (name "rust-psl")