diff mbox series

[bug#61391,1/6] gnu: icedove-wayland: Use gexps.

Message ID 20230209163744.28973-2-maxim.cournoyer@gmail.com
State New
Headers show
Series Improvements to Icedove (icons, gexps, un-bundling) | expand

Commit Message

Maxim Cournoyer Feb. 9, 2023, 4:37 p.m. UTC
* gnu/packages/gnuzilla.scm (icedove/wayland)
[inputs]: Set to the empty list.
[arguments]: Use gexps.
---

 gnu/packages/gnuzilla.scm | 35 ++++++++++++++---------------------
 1 file changed, 14 insertions(+), 21 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 0b39774a2e..15472ffed2 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1420,37 +1420,30 @@  (define-public icedove/wayland
   (package
     (inherit icedove)
     (name "icedove-wayland")
-    (native-inputs '())
-    (inputs
-     `(("bash" ,bash-minimal)
-       ("icedove" ,icedove)))
     (build-system trivial-build-system)
     (arguments
-      '(#:modules ((guix build utils))
-        #:builder
-        (begin
+     (list
+      #:modules '((guix build utils))
+      #:builder
+      #~(begin
           (use-modules (guix build utils))
-          (let* ((bash    (assoc-ref %build-inputs "bash"))
-                 (icedove (assoc-ref %build-inputs "icedove"))
-                 (out     (assoc-ref %outputs "out"))
-                 (exe     (string-append out "/bin/icedove")))
+          (let* ((exe (string-append #$output "/bin/icedove")))
             (mkdir-p (dirname exe))
-
             (call-with-output-file exe
               (lambda (port)
                 (format port "#!~a
  MOZ_ENABLE_WAYLAND=1 exec ~a $@"
-                        (string-append bash "/bin/bash")
-                        (string-append icedove "/bin/icedove"))))
+                        #$(file-append bash-minimal "/bin/bash")
+                        #$(file-append icedove "/bin/icedove"))))
             (chmod exe #o555)
-
             ;; Provide the manual and .desktop file.
-            (copy-recursively (string-append icedove "/share")
-                              (string-append out "/share"))
-            (substitute* (string-append
-                          out "/share/applications/icedove.desktop")
-              ((icedove) out))
-            #t))))))
+            (copy-recursively (string-append #$icedove "/share")
+                              (string-append #$output "/share"))
+            (substitute* (string-append #$output
+                                        "/share/applications/icedove.desktop")
+              ((#$icedove) #$output))))))
+    (native-inputs '())
+    (inputs '())))
 
 (define-public firefox-decrypt
   (package