diff mbox series

[bug#61349] gnu: Add ghc-hs-conllu

Message ID 20230207194209.1fb88dd8@ens-lyon.fr
State New
Headers show
Series [bug#61349] gnu: Add ghc-hs-conllu | expand

Commit Message

Alice BRENON Feb. 7, 2023, 6:42 p.m. UTC
Hey Guix !

I've discovered this haskell library to parse syntax-annotated files and found
it useful so I packaged it for you.

Hope you like it,

Alice

Comments

Christopher Baines March 1, 2023, 3:53 p.m. UTC | #1
Alice BRENON <alice.brenon@ens-lyon.fr> writes:

> Hey Guix !
>
> I've discovered this haskell library to parse syntax-annotated files and found
> it useful so I packaged it for you.

Thanks, I've pushed this to master as
4ccba48de14cc10f40abb1a5237749346222b6e7.

Chris
diff mbox series

Patch

From d61965f2bc28b046c9d73a53ba727add8c3a0e1f Mon Sep 17 00:00:00 2001
From: Alice BRENON <alice.brenon@ens-lyon.fr>
Date: Tue, 7 Feb 2023 11:05:47 +0100
Subject: [PATCH] gnu: Add ghc-hs-conllu

* gnu/packages/haskell-xyz (ghc-hs-conllu): New variable
---
 gnu/packages/haskell-xyz.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 79b4ae7bed..31284db7ee 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,7 +28,7 @@ 
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
 ;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
-;;; Copyright © 2021, 2022 Alice BRENON <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021–2023 Alice BRENON <alice.brenon@ens-lyon.fr>
 ;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
@@ -5911,6 +5911,26 @@  (define-public ghc-hs-bibutils
 MODS-format XML intermediate.")
     (license license:gpl2+)))
 
+(define-public ghc-hs-conllu
+  (package
+    (name "ghc-hs-conllu")
+    (version "0.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "hs-conllu" version))
+              (sha256
+               (base32
+                "1azh4g5kdng8v729ldgblkmrdqrc501rgm9wwqx6gkqwwzn8w3r4"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-megaparsec ghc-void))
+    (home-page "https://github.com/arademaker/hs-conllu")
+    (synopsis "CoNLL-U validating parser and utils")
+    (description
+     "Utilities to parse, print, diff, and analyse data in CoNLL-U, a format
+used in linguistics to represent the syntactic annotation of sentences.  See
+@url{https://universaldependencies.org/format.html}")
+    (license license:lgpl3)))
+
 (define-public ghc-hslogger
   (package
     (name "ghc-hslogger")
-- 
2.39.1