diff mbox series

[bug#61336,09/10] gnu: Remove azr3.

Message ID 20230207041925.6292-10-maxim.cournoyer@gmail.com
State New
Headers show
Series Remove lash, which causes gtk@4 to depend on python2 | expand

Commit Message

Maxim Cournoyer Feb. 7, 2023, 4:19 a.m. UTC
* gnu/packages/audio.scm (azr3): Delete variable.
---

 gnu/packages/audio.scm | 41 -----------------------------------------
 1 file changed, 41 deletions(-)

Comments

Ricardo Wurmus Feb. 7, 2023, 9:33 a.m. UTC | #1
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> * gnu/packages/audio.scm (azr3): Delete variable.

Why delete this?
Ricardo Wurmus Feb. 7, 2023, 10:15 a.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> * gnu/packages/audio.scm (azr3): Delete variable.
>
> Why delete this?

I’ve pushed a series of commits to build azr3 without lash.  The other
commits look good to me, but I suspect that you can’t do the fluidsynth
change (and the removal of lash) on the master branch.
Maxim Cournoyer Feb. 7, 2023, 1:48 p.m. UTC | #3
Hi Ricardo,

Ricardo Wurmus <rekado@elephly.net> writes:

> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>>> * gnu/packages/audio.scm (azr3): Delete variable.
>>
>> Why delete this?
>
> I’ve pushed a series of commits to build azr3 without lash.  The other
> commits look good to me, but I suspect that you can’t do the fluidsynth
> change (and the removal of lash) on the master branch.

Thanks for taking a look and preserving azr3.  The change to fluidsynth
would require 818 dependent packages to be rebuilt, many of them Python
packages.  I've sent it to staging; with the rest merged to master.
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0a2d87784e..c600a3f751 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1090,47 +1090,6 @@  (define-public autotalent
     ;; The FFT routine is under BSD-3.
     (license license:gpl2+)))
 
-(define-public azr3
-  (package
-    (name "azr3")
-    (version "1.2.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://savannah/ll-plugins/azr3-jack-"
-                                  version
-                                  ".tar.bz2"))
-              (sha256
-               (base32
-                "18mdw6nc0vgj6k9rsy0x8w64wvzld0frqshrxxbxfj9qi9843vlc"))
-              (patches (search-patches "azr3.patch"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:tests? #f ; no check target
-       #:make-flags
-       (list "LV2PEG=ttl2c"
-             (string-append "prefix=" %output)
-             (string-append "pkgdatadir=" %output "/share/azr3-jack"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'fix-timestamp
-           (lambda _
-             (let ((early-1980 315619200)) ; 1980-01-02 UTC
-               (utime "azr3.1" early-1980 early-1980))
-             #t)))))
-    (inputs
-     (list gtkmm-2 lvtk jack-1 lash))
-    (native-inputs
-     (list pkg-config))
-    (home-page "http://ll-plugins.nongnu.org/azr3/")
-    (synopsis "Tonewheel organ synthesizer")
-    (description
-     "AZR-3 is a port of the free VST plugin AZR-3.  It is a tonewheel organ
-with drawbars, distortion and rotating speakers.  The organ has three
-sections, two polyphonic sections with nine drawbars each and one monophonic
-bass section with five drawbars.  A standalone JACK application and LV2
-plugins are provided.")
-    (license license:gpl2)))
-
 (define-public calf
   (package
     (name "calf")