[bug#61331,5/6] gnu: Update libinput to 1.22.1.
Commit Message
From 4daaffccca2ba1e89592b7302a6e9c9c92428fcc Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 01:06:50 +0100
Subject: [PATCH 5/6] gnu: Update libinput to 1.22.1.
* gnu/packages/freedesktop.scm (libinput): Update to version 1.22.1. [inputs]
Add python.
---
gnu/packages/freedesktop.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)
@@ -589,14 +589,16 @@ (define-public libinput
;; Updating this will rebuild over 700 packages through libinput-minimal.
(package
(name "libinput")
- (version "1.19.4")
+ (version "1.22.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://freedesktop.org/software/libinput/"
- "libinput-" version ".tar.xz"))
+ (method git-fetch)
+
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libinput/libinput.git")
+ (commit version)))
(sha256
(base32
- "0h5lz54rrl48bhi3vki6s08m6rn2h62rlf08dhgchdm9nmqaaczz"))))
+ "17a5qlym2d6lg2j8fdpxda9k7x5zr35flb4wlj1bz7h0mnkh8326"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Ddocumentation=false")
@@ -613,7 +615,8 @@ (define-public libinput
gtk+
libevdev
libwacom
- mtdev))
+ mtdev
+ python))
(propagated-inputs
`(;; libinput.h requires <libudev.h>, so propagate it.
("udev" ,eudev)))