[bug#61331,core-updates] Update wayland, ..., sway
Commit Message
From 1e06a38d5deca1982d275c00ad61531d67869423 Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sun, 5 Feb 2023 00:22:52 +0100
Subject: [PATCH 1/6] gnu: Update wayland to 1.21.0.
* gnu/packages/freedesktop.scm (wayland): Update to version 1.21.0.
---
gnu/packages/freedesktop.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
@@ -1174,19 +1174,20 @@ (define-public python-pyxdg
(define-public wayland
(package
(name "wayland")
- (version "1.20.0")
+ (version "1.21.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://wayland.freedesktop.org/releases/"
+ (uri (string-append "https://gitlab.freedesktop.org/wayland/"
+ name "/-/releases/" version "/downloads/"
name "-" version ".tar.xz"))
(sha256
(base32
- "09c7rpbwavjg4y16mrfa57gk5ix6rnzpvlnv1wp7fnbh9hak985q"))))
+ "1b0ixya9bfw5c9jx8mzlr7yqnlyvd3jv5z8wln9scdv8q5zlvikd"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
`(#:parallel-tests? #f
- #:phases
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-docbook-xml
(lambda* (#:key native-inputs inputs #:allow-other-keys)