diff mbox series

[bug#57337,v3,1/2] gnu: Add miniz-cpp.

Message ID 20230205201833.24156-1-wz@freeshell.de
State New
Headers show
Series [bug#57337,v3,1/2] gnu: Add miniz-cpp. | expand

Commit Message

Wiktor Żelazny Feb. 5, 2023, 8:18 p.m. UTC
* gnu/packages/cpp.scm (miniz-cpp): New variable.
---
 gnu/packages/cpp.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)


base-commit: 4b9e1e84585270a40cec485046ce15387405d256
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 6fa4c0f7a0..61a9aa37c2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2427,3 +2427,38 @@  (define-public ftxui
 @item No dependencies.
 @end itemize")
     (license license:expat)))
+
+(define-public miniz-cpp
+  (let ((commit "64f974213ac16f78c008bd148c8a2a07e902f148")
+        (revision "1"))
+    (package
+      (name "miniz-cpp")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      ;; A fork repository that includes a patch necessary to get docxbox
+                      ;; to compile. The patch is too big to be included in Guix. To be
+                      ;; replaced with https://github.com/tfussell/miniz-cpp once
+                      ;; https://github.com/tfussell/miniz-cpp/pull/11 gets merged.
+                      (url "https://github.com/kstenschke/miniz-cpp")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1qm88545kch91dz3cbgl2cbkg6wjas3h399hm5c2pbqi8jycz6vy"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("zip_file.hpp" "include/")
+                          ("LICENSE.md" "share/doc/miniz-cpp/")
+                          ("README.md" "share/doc/miniz-cpp/")
+                          ("examples" "share/doc/miniz-cpp/"))))
+      (home-page "https://github.com/tfussell/miniz-cpp/")
+      (synopsis
+       "Cross-platform header-only C++14 library for reading and writing
+ZIP files")
+      (description
+       "@code{miniz-cpp} is a cross-platform header-only library for
+reading and writing ZIP files using a nice simple API similar to Python's
+@command{zipfile}.")
+      (license license:expat))))