diff mbox series

[bug#61229,2/2] gnu: Add python-demuxem.

Message ID 20230202160023.45975-2-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61230,1/2] gnu: Add python-pegasusio. | expand

Commit Message

nafkhamdc Feb. 2, 2023, 4 p.m. UTC
* gnu/packages/bioinformatics.scm (python-demuxem): New variable.
---
 gnu/packages/bioinformatics.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Ricardo Wurmus Feb. 2, 2023, 11:25 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6caf0e4cfa..406f8616c7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1090,6 +1090,35 @@  (define-public python-cmseq
 and sequence consensus.")
     (license license:expat)))
 
+(define-public python-demuxem
+  (package
+    (name "python-demuxem")
+    (version "0.1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "demuxEM" version))
+              (sha256
+               (base32
+                "1bhyxqjk44bmyd26m1smapf68wyf7252kk65i27k50dd3kswgnd6"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-docopt
+                             python-importlib-metadata
+                             python-numpy
+                             python-pandas
+                             python-pegasusio
+                             python-scikit-learn
+                             python-scipy
+                             python-seaborn))
+    (native-inputs (list python-cython python-setuptools-scm))
+    (home-page "https://github.com/lilab-bcb/demuxEM")
+    (synopsis
+     "This is a module on analyzing cell-hashing/nucleus-hashing data")
+    (description
+     "This is a module on analyzing cell-hashing/nucleus-hashing data.
+It is the demultiplexing module of Pegasus, which is used by Cumulus
+in demultiplexing step.")
+    (license license:bsd-3)))
+
 (define-public python-hclust2
   (package
     (name "python-hclust2")