diff mbox series

[bug#61130,v2,1/2] gnu: wxwidgets: Remove configure option

Message ID 20230202063940.313-1-atai@atai.org
State New
Headers show
Series [bug#61130,v2,1/2] gnu: wxwidgets: Remove configure option | expand

Commit Message

Andy Tai Feb. 2, 2023, 6:39 a.m. UTC
* gnu/packages/wxwidgets.scm (wxwidgets): Remove
configure option that prevented webview option
from being in build and wxconfig feature list
---
 gnu/packages/wxwidgets.scm | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)


base-commit: 43eed907d22b094c5a9b2931ca5e72caf2b95991
diff mbox series

Patch

diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 0183e07c31..0a93c30f26 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -120,20 +120,12 @@  (define-public wxwidgets
                             "--with-sdl"
                             "--enable-gui"
                             "--enable-mediactrl"
-                            "--enable-webview"
-                            "--enable-webviewwebkit")
+                            "--enable-webview")
       #:make-flags
       #~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
       #:tests? #f                       ;TODO
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'use-newer-webkit
-            (lambda _
-              ;; XXX: The configure script tests only for an ancient
-              ;; WebKitGTK version.
-              (substitute* "configure"
-                (("webkit2gtk-4\\.0")
-                 "webkit2gtk-4.1"))))
           (add-after 'unpack 'refer-to-inputs
             (lambda* (#:key inputs #:allow-other-keys)
               (let ((catch (search-input-file inputs "include/catch.hpp"))