diff mbox series

[bug#61218] gnu: Add emacs-hexrgb.

Message ID 20230201203559.15384-1-antero@mailbox.org
State New
Headers show
Series [bug#61218] gnu: Add emacs-hexrgb. | expand

Commit Message

Antero Mejr Feb. 1, 2023, 8:35 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-hexrgb): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ba2916a463..7dfa98f6ba 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35602,6 +35602,34 @@  (define-public emacs-vertico-posframe
 a vertical completion UI.")
     (license license:gpl3+)))
 
+(define-public emacs-hexrgb
+  (package
+    (name "emacs-hexrgb")
+    (version "961")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emacsmirror/hexrgb")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1j073dyzl343zh0nygldf9z3ixa57picq39a95mlz0p4pf6fmpx7"))))
+    (build-system emacs-build-system)
+    (home-page "https://www.emacswiki.org/emacs/hexrgb.el")
+    (synopsis "Emacs functions to convert color formats")
+    (description
+     "@code{hexrgb.el} provides functions for converting between RGB
+(red, green, blue) color components and HSV (hue, saturation, value) color
+components.  It converts:
+@itemize
+@item Emacs color components (whole numbers from 0 through 65535)
+@item RGB and HSV floating-point components (0.0 through 1.0)
+@item Emacs color-name strings (such as \"blue\")
+@item hex RGB color strings (such as \"#FC43A7912\")
+@end itemize")
+    (license license:gpl2+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar