diff mbox series

[bug#61218] gnu: Add emacs-srv.

Message ID 20230201203505.15277-1-antero@mailbox.org
State New
Headers show
Series [bug#61218] gnu: Add emacs-srv. | expand

Commit Message

Antero Mejr Feb. 1, 2023, 8:35 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-srv): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7dfa98f6ba..b98798a7d2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35630,6 +35630,29 @@  (define-public emacs-hexrgb
 @end itemize")
     (license license:gpl2+)))
 
+(define-public emacs-srv
+  (package
+    (name "emacs-srv")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/legoscia/srv.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1a8pqhdi7m3lis5ad2f74s1sy8zpxlwvfsvd80lw746235x2v06z"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/legoscia/srv.el")
+    (synopsis "Emacs Lisp library to perform SRV DNS requests")
+    (description
+     "@code{srv.el} implements RFC 2782 (SRV records).  It is used to look up
+hostname and port for a service at a specific domain.  There might be multiple
+results, and the caller is supposed to attempt to connect to each hostname+port
+in turn.")
+    (license license:gpl2+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar