diff mbox series

[bug#61199] gnu: Remove valgrind-3.20.

Message ID 20230131103229.904755-1-zimon.toutoune@gmail.com
State New
Headers show
Series [bug#61199] gnu: Remove valgrind-3.20. | expand

Commit Message

Simon Tournier Jan. 31, 2023, 10:32 a.m. UTC
* gnu/packages/valgrind.scm (valgrind-3.20): Delete variable.
(valgrind/interactive): Update to 3.20.0.
---
 gnu/packages/valgrind.scm | 22 +++-------------------
 1 file changed, 3 insertions(+), 19 deletions(-)

Hi,

The patch is a follow up of [1].  It removes an unnecessary version of
Valgrind.

The patch does not imply any rebuild.

1: <https://yhetil.org/guix/Y9EMD7rjSuI5pdef@jurong>


Cheers,
simon



base-commit: a3b57e57e68a1f4848bf8bacd797c5d989f56de2

Comments

Ludovic Courtès Feb. 8, 2023, 10:36 p.m. UTC | #1
Hi,

Simon Tournier <zimon.toutoune@gmail.com> skribis:

> * gnu/packages/valgrind.scm (valgrind-3.20): Delete variable.
> (valgrind/interactive): Update to 3.20.0.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 422e542918..bd08dffc83 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2022 Denis Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -96,7 +97,7 @@  (define-public valgrind
 (define-public valgrind/interactive
   (package/inherit
    valgrind
-   (version "3.17.0")
+   (version "3.20.0")
    (source (origin
              (method url-fetch)
              (uri (list (string-append "https://sourceware.org/pub/valgrind"
@@ -105,9 +106,8 @@  (define-public valgrind/interactive
                                        "/valgrind-" version ".tar.bz2")))
              (sha256
               (base32
-               "18l5jbk301j3462gipqn9bkfx44mdmwn0pwr73r40gl1irkfqfmd"))
+               "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))
              (patches (search-patches
-                       "valgrind-enable-arm.patch"
                        "valgrind-fix-default-debuginfo-path.patch"))))
    (inputs
     ;; GDB is needed to provide a sane default for `--db-command'.
@@ -148,19 +148,3 @@  (define libc-debug
                       (string-length "/usr/lib/debug")
                       1))))))))))
    (properties '())))
-
-(define-public valgrind-3.20
-  (package
-    (inherit valgrind/interactive)
-    (version "3.20.0")
-    (source (origin
-              (inherit (package-source valgrind/interactive))
-              (uri (list (string-append "https://sourceware.org/pub/valgrind"
-                                        "/valgrind-" version ".tar.bz2")
-                         (string-append "ftp://sourceware.org/pub/valgrind"
-                                        "/valgrind-" version ".tar.bz2")))
-              (sha256
-               (base32
-                "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))
-              (patches (search-patches
-                        "valgrind-fix-default-debuginfo-path.patch"))))))