diff mbox series

[bug#61191] gnu: Fix missing libcap dependency for mako.

Message ID 20230131011824.6225-1-raingloom@riseup.net
State New
Headers show
Series [bug#61191] gnu: Fix missing libcap dependency for mako. | expand

Commit Message

Csepp Jan. 31, 2023, 1:18 a.m. UTC
* gnu/packages/wm.scm (mako)[inputs]: Add libcap.
---
Should solve upgrade headaches for Sway users like myself.

 gnu/packages/wm.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

itd Jan. 31, 2023, 6:06 p.m. UTC | #1
Hi,

these two patches (61145, 61191) seem to address the same issue.  (But
I'm not sure libcap should be in input or in native-inputs.  Both
versions build here.)

Best regards
itd
Jelle Licht Feb. 9, 2023, 2:29 p.m. UTC | #2
I went ahead and pushed the solution posted with issue #61213 to master,
but thanks everyone and anyone who {reported,fixed} this issue!

- Jelle
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2fd70af07f..2b552e5359 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1857,7 +1857,7 @@  (define-public mako
                       (string-append
                        (search-input-file inputs "bin/jq")
                        " "))))))))
-    (inputs (list basu cairo gdk-pixbuf jq pango wayland))
+    (inputs (list basu cairo gdk-pixbuf jq libcap pango wayland))
     (native-inputs (list pkg-config scdoc wayland-protocols))
     (home-page "https://wayland.emersion.fr/mako")
     (synopsis "Lightweight Wayland notification daemon")