diff mbox series

[bug#61145] Added libcap to the native inputs of mako.

Message ID 20230129111521.24921-1-samuel@nihil.ws
State New
Headers show
Series [bug#61145] Added libcap to the native inputs of mako. | expand

Commit Message

Samuel Matthiesen Jan. 29, 2023, 11:15 a.m. UTC
Hi Guix,

I have prepared this patch to fix the build of mako 1.7.1. Here is the failed build log:
http://ci.guix.gnu.org/build/370206/details

I'm not sure if this is the correct way to address this issue, but in my local tests it fixes the build.

Samuel

***

This allows pkg-config to detect libcap during the build of mako. This is used
by meson to generate cargs for basu (a dependency of mako), which in turn
needs libcap.

* gnu/packages/wm.scm (mako)[native-inputs]: Added libcap
---
 gnu/packages/wm.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

itd Jan. 31, 2023, 6:06 p.m. UTC | #1
Hi,

these two patches (61145, 61191) seem to address the same issue.  (But
I'm not sure libcap should be in input or in native-inputs.  Both
versions build here.)

Best regards
itd
Josselin Poiret Feb. 1, 2023, 5:15 p.m. UTC | #2
Hi,

itd@net.in.tum.de writes:

> Hi,
>
> these two patches (61145, 61191) seem to address the same issue.  (But
> I'm not sure libcap should be in input or in native-inputs.  Both
> versions build here.)

Just to add one more patch to the list, I just sent [1] which should be
the "proper fix", propagating libcap from basu itself.

[1] https://issues.guix.gnu.org/61213
    (29854884695de3d32b2fb8899e49282aaec74c9e.1675270507.git.dev@jpoiret.xyz)

Best,
Jelle Licht Feb. 9, 2023, 2:29 p.m. UTC | #3
I went ahead and pushed the solution posted with issue #61213 to master,
but thanks everyone and anyone who {reported,fixed} this issue!

- Jelle
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2fd70af07f..f17bc0af3f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1858,7 +1858,7 @@  (define-public mako
                        (search-input-file inputs "bin/jq")
                        " "))))))))
     (inputs (list basu cairo gdk-pixbuf jq pango wayland))
-    (native-inputs (list pkg-config scdoc wayland-protocols))
+    (native-inputs (list libcap pkg-config scdoc wayland-protocols))
     (home-page "https://wayland.emersion.fr/mako")
     (synopsis "Lightweight Wayland notification daemon")
     (description "Mako is a lightweight notification daemon for Wayland