diff mbox series

[bug#59059,v2] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2

Message ID 20230128092503.23970-1-atai@atai.org
State New
Headers show
Series [bug#59059,v2] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2 | expand

Commit Message

Andy Tai Jan. 28, 2023, 9:25 a.m. UTC
* gnu/packages/gnome.scm (gnome-terminator): Rename variable from
(terminator):  …this.  Redefine using DEPRECATED-PACKAGE.
Update to 2.1.2
---
 gnu/packages/gnome.scm | 123 ++++++++++++++++++++++-------------------
 1 file changed, 67 insertions(+), 56 deletions(-)

Comments

宋文武 Jan. 29, 2023, 6:19 a.m. UTC | #1
Andy Tai <atai@atai.org> writes:

> * gnu/packages/gnome.scm (gnome-terminator): Rename variable from
> (terminator):  …this.  Redefine using DEPRECATED-PACKAGE.
> Update to 2.1.2

Hello, I have commit the 2.1.2 update.

Why rename it to gnome-terminator?  I think terminator is fine, because
that in ArchLinux the package named so, and its executeble is
'terminator' not 'gnome-terminator'.
Andy Tai Jan. 29, 2023, 6:22 a.m. UTC | #2
Hi, I saw there are other software packages named "terminator" (on Mac
OS, I think) and I am afraid of name collisions.   Also the
maintainers of the terminator package use the term gnome-terminator in
their own documentation ,  website, etc.  I guess it is better to be
specific as this is something in the GNOME ecosystem.

Thanks

On Sat, Jan 28, 2023 at 10:19 PM 宋文武 <iyzsong@envs.net> wrote:
>
> Andy Tai <atai@atai.org> writes:
>
> > * gnu/packages/gnome.scm (gnome-terminator): Rename variable from
> > (terminator):  …this.  Redefine using DEPRECATED-PACKAGE.
> > Update to 2.1.2
>
> Hello, I have commit the 2.1.2 update.
>
> Why rename it to gnome-terminator?  I think terminator is fine, because
> that in ArchLinux the package named so, and its executeble is
> 'terminator' not 'gnome-terminator'.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index de5b5df450..1d64b106c4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11929,41 +11929,45 @@  (define-public gthumb
 advanced image management tool")
     (license license:gpl2+)))
 
-(define-public terminator
+(define-public gnome-terminator
   (package
-    (name "terminator")
-    (version "2.1.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/gnome-terminator/terminator/"
-                           "releases/download/v" version "/"
-                           name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0xdgmam7ghnxw6g38a4gjw3kk3rhga8c66lns18k928jlr9fmddw"))))
+    (name "gnome-terminator")
+    (version "2.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/gnome-terminator/terminator/"
+                    "releases/download/v"
+                    version
+                    "/"
+                    "terminator"
+                    "-"
+                    version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "10shpn8id7z43d4dpx16x76mgxnk4mr976j5cg28icjiiaidyfc2"))))
     (build-system python-build-system)
-    (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("glib:bin" ,glib "bin")         ; for glib-compile-resources
-       ("gobject-introspection" ,gobject-introspection)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("python-psutil" ,python-psutil)
-       ("python-pytest-runner" ,python-pytest-runner)
-       ("python-pytest" ,python-pytest)))
-    (inputs
-     `(("cairo" ,cairo)
-       ("dbus-glib" ,dbus-glib)
-       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("gtk+" ,gtk+)
-       ("python" ,python-wrapper)
-       ("python-dbus" ,python-dbus)
-       ("python-notify2" ,python-notify2)
-       ("python-pycairo" ,python-pycairo)
-       ("python-pygobject" ,python-pygobject)
-       ("vte" ,vte)))
-    (propagated-inputs
-     (list python-configobj))
+    (native-inputs (list gettext-minimal
+                         `(,glib "bin") ;for glib-compile-resources
+                         gobject-introspection
+                         intltool
+                         pkg-config
+                         python-psutil
+                         python-pytest-runner
+                         python-pytest))
+    (inputs (list bash-minimal
+    		      cairo
+                  dbus-glib
+                  gsettings-desktop-schemas
+                  gtk+
+                  python-wrapper
+                  python-dbus
+                  python-notify2
+                  python-pycairo
+                  python-pygobject
+                  vte))
+    (propagated-inputs (list python-configobj))
     (arguments
      ;; One test out of 28 fails due to dbus-python and python-notify; skip
      ;; tests.
@@ -11971,30 +11975,34 @@  (define-public terminator
        #:imported-modules ((guix build glib-or-gtk-build-system)
                            ,@%python-build-system-modules)
        #:modules ((guix build python-build-system)
-                  ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+                  ((guix build glib-or-gtk-build-system)
+                   #:prefix glib-or-gtk:)
                   (guix build utils))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'handle-dbus-python
-           (lambda _
-             ;; python-dbus cannot be found but it's really there.  See
-             ;; https://github.com/SpotlightKid/jack-select/issues/2
-             (substitute* "setup.py"
-               (("'dbus-python',") ""))))
-         (add-after 'install 'wrap-program
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((prog (string-append (assoc-ref outputs "out")
-                                        "/bin/terminator"))
-                   (pylib (string-append (assoc-ref outputs "out")
-                                         "/lib/python"
-                                         ,(version-major+minor
-                                           (package-version python))
-                                         "/site-packages")))
-               (wrap-program prog
-                 `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
-                 `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))
-         (add-after 'wrap-program 'glib-or-gtk-wrap
-           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'handle-dbus-python
+                    (lambda _
+                      ;; python-dbus cannot be found but it's really there.  See
+                      ;; https://github.com/SpotlightKid/jack-select/issues/2
+                      (substitute* "setup.py"
+                        (("'dbus-python',")
+                         ""))))
+                  (add-after 'install 'wrap-program
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let ((prog (string-append (assoc-ref outputs "out")
+                                                 "/bin/terminator"))
+                            (pylib (string-append (assoc-ref outputs "out")
+                                                  "/lib/python"
+                                                  ,(version-major+minor (package-version
+                                                                         python))
+                                                  "/site-packages")))
+                        (wrap-program prog
+                                      `("GUIX_PYTHONPATH" =
+                                        (,(getenv "GUIX_PYTHONPATH") ,pylib))
+                                      `("GI_TYPELIB_PATH" =
+                                        (,(getenv "GI_TYPELIB_PATH")))))))
+                  (add-after 'wrap-program 'glib-or-gtk-wrap
+                    (assoc-ref glib-or-gtk:%standard-phases
+                               'glib-or-gtk-wrap)))))
     (home-page "https://gnome-terminator.org/")
     (synopsis "Store and run multiple GNOME terminals in one window")
     (description
@@ -12002,6 +12010,9 @@  (define-public terminator
 tabs, and it supports drag and drop re-ordering of terminals.")
     (license license:gpl2)))
 
+(define-public terminator
+    (deprecated-package "terminator" gnome-terminator))
+
 (define-public libhandy
   (package
     (name "libhandy")