diff mbox series

[bug#60937,v2,1/2] gnu: wxwidgets: Reove configure option

Message ID 20230128085644.22453-1-atai@atai.org
State New
Headers show
Series [bug#60937,v2,1/2] gnu: wxwidgets: Reove configure option | expand

Commit Message

Andy Tai Jan. 28, 2023, 8:56 a.m. UTC
* gnu/packages/wxwidgets.scm (wxwidgets): Remove
configure option that prevented webview option
from being in build and wxconfig feature list
---
 gnu/packages/wxwidgets.scm | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)

Comments

Simon Tournier Jan. 30, 2023, 12:37 p.m. UTC | #1
Hi,

Typo on the commit message.

s/Reove/Remove.


Cheers,
simon
Andy Tai Jan. 30, 2023, 3:33 p.m. UTC | #2
fixed as Issue 61130

61130@debbugs.gnu.org

(I created a new issue so Guix QA can pick it up for testing)

On Mon, Jan 30, 2023 at 4:47 AM Simon Tournier <zimon.toutoune@gmail.com>
wrote:

> Hi,
>
> Typo on the commit message.
>
> s/Reove/Remove.
>
>
> Cheers,
> simon
>
diff mbox series

Patch

diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 0183e07c31..0a93c30f26 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -120,20 +120,12 @@  (define-public wxwidgets
                             "--with-sdl"
                             "--enable-gui"
                             "--enable-mediactrl"
-                            "--enable-webview"
-                            "--enable-webviewwebkit")
+                            "--enable-webview")
       #:make-flags
       #~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
       #:tests? #f                       ;TODO
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'use-newer-webkit
-            (lambda _
-              ;; XXX: The configure script tests only for an ancient
-              ;; WebKitGTK version.
-              (substitute* "configure"
-                (("webkit2gtk-4\\.0")
-                 "webkit2gtk-4.1"))))
           (add-after 'unpack 'refer-to-inputs
             (lambda* (#:key inputs #:allow-other-keys)
               (let ((catch (search-input-file inputs "include/catch.hpp"))