diff mbox series

[bug#61010,v3] gnu: Add icewm

Message ID 20230128082221.20893-1-atai@atai.org
State New
Headers show
Series [bug#61010,v3] gnu: Add icewm | expand

Commit Message

Andy Tai Jan. 28, 2023, 8:22 a.m. UTC
* gnu/packages/wm.scm (icewm): New variable
---
 gnu/packages/wm.scm | 66 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 66 insertions(+)


base-commit: c6ec9c7af9814f84f293f62235eab9d0649751a7

Comments

宋文武 Feb. 10, 2023, 2:05 a.m. UTC | #1
Andy Tai <atai@atai.org> writes:

> * gnu/packages/wm.scm (icewm): New variable

Pushed with some modifications:
- update to 3.3.1.
- change license to 'lgpl2.0'.
- use gexp for arguments.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a860ed1f93..52d2321257 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -100,6 +100,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages check)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
@@ -763,6 +764,71 @@  (define-public i3lock-fancy
 desktop environment.")
     (license license:expat)))
 
+(define-public icewm
+  (package
+    (name "icewm")
+    (version "3.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/ice-wm/icewm/releases/download/"
+                    version "/icewm-" version ".tar.lz"))
+              (sha256
+               (base32
+                "14vkv5r9rvwfj8gmdsrkkq7vxvk2j7z7wfybzc8ywj469yya5ppq"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list fontconfig
+                  fribidi
+                  imlib2
+                  libice
+                  libjpeg-turbo
+                  libsm
+                  libxcomposite
+                  libxdamage
+                  libxext
+                  libxfixes
+                  libxft
+                  libxinerama
+                  libxpm
+                  libxrandr
+                  libxrender
+                  libx11
+                  lzip
+                  perl))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'remove-gmo-files
+                    ;; gmo files are generated from .po files
+                    ;; so remove them before build to make sure
+                    ;; they are re-generated if needed
+                    (lambda _
+                      (for-each delete-file
+                                (find-files "po" "\\.gmo$")) #t))
+                  (add-after 'unpack 'skip-failing-test
+                    ;; strtest.cc tests failing due to $HOME and /etc setup
+                    ;; difference under guix
+                    (lambda _
+                      (substitute* "src/Makefile.in"
+                        (("TESTS = strtest\\$\\(EXEEXT\\)")
+                         "TESTS = ")) #t)))))
+    (home-page "https://ice-wm.org/")
+    (synopsis "Window manager for the X Window System")
+    (description
+     "IceWM is a window manager for the X Window System.  The goal of
+IceWM is speed, simplicity, and not getting in the user’s way.  It comes with a
+taskbar with pager, global and per-window keybindings and a dynamic menu system.
+Application windows can be managed by keyboard and mouse.  Windows
+can be iconified to the taskbar, to the tray, to the desktop or be made
+hidden.  They are controllable by a quick switch window (Alt+Tab) and in a
+window list.  A handful of configurable focus models are
+menu-selectable.  Setups with multiple monitors are supported by RandR and
+Xinerama.  IceWM is very configurable, themeable and well documented.  It
+includes an optional external background wallpaper manager with transparency
+support, a simple session manager and a system tray.")
+    (license license:gpl2)))
+
+
 (define-public xmonad-next
   (package
     (name "xmonad-next")