diff mbox series

[bug#61085] gnu: shellcheck: Update to 0.9.0.

Message ID 20230126204543.256426-1-code@greghogan.com
State New
Headers show
Series [bug#61085] gnu: shellcheck: Update to 0.9.0. | expand

Commit Message

Greg Hogan Jan. 26, 2023, 8:45 p.m. UTC
* gnu/packages/haskell-apps.scm (shellcheck): Update to 0.9.0.
[inputs]: Add ghc-fgl.
---
 gnu/packages/haskell-apps.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Christopher Baines Feb. 1, 2023, 8:53 a.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/haskell-apps.scm (shellcheck): Update to 0.9.0.
> [inputs]: Add ghc-fgl.
> ---
>  gnu/packages/haskell-apps.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

Thanks, I've pushed this to master as
f9f1312de061c5d38b0ca260f306e9ba5a4c7a43.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 9cb383eeb2..64dde4d313 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -842,7 +842,7 @@  (define-public scroll
 (define-public shellcheck
   (package
     (name "shellcheck")
-    (version "0.8.0")
+    (version "0.9.0")
     (source
      (origin
        (method url-fetch)
@@ -850,7 +850,7 @@  (define-public shellcheck
              "https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
              version ".tar.gz"))
        (sha256
-        (base32 "05jlapp4m997w36h2wszdxz9gvczdczaylypsbn14jqpb650w232"))
+        (base32 "071k2gc8rzpg9lwq9g10c9xx0zm1wcgsf8v4n1csj9fm56vy7gmb"))
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system haskell-build-system)
     (arguments
@@ -868,7 +868,7 @@  (define-public shellcheck
     (native-inputs
      (list pandoc))
     (inputs
-     (list ghc-aeson ghc-diff ghc-quickcheck ghc-regex-tdfa))
+     (list ghc-aeson ghc-diff ghc-fgl ghc-quickcheck ghc-regex-tdfa))
     (home-page "https://www.shellcheck.net/")
     (synopsis "Static analysis for shell scripts")
     (description "@code{shellcheck} provides static analysis for